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Preface

This section describes the purpose and organization of this guide: Getting Started 
with the Oracle Standard Management Pack. Specifically, it covers the following topics:

■ Purpose of This Guide

■ Audience

■ How This Guide Is Organized

■ Conventions Used in This Guide

■ Oracle Enterprise Manager Pack Information

■ Related Publications

■ Oracle Enterprise Manager Documentation

■ Oracle Support

■ Documentation Accessibility

■ How to Find Oracle Documentation Online

Purpose of This Guide
This guide provides an overview of the Oracle Standard Management Pack 
applications and their features.  As the guide describes how to use the Oracle 
Standard Management Pack applications, it also introduces you to key concepts and 
terminology in the following products: Oracle Performance Manager, Oracle Index 
Tuning Wizard, Oracle Baseline Viewer, Oracle Change Manager, Oracle Create 
Baseline, Oracle Compare Database Objects, and Oracle TopSessions charts.
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Audience
This guide is written for Oracle Standard Management Pack users who want to 
monitor and diagnose problems, tune high impact indexes, and track and compare 
changes in their Oracle environment.

How This Guide Is Organized
This guide is organized as follows:

Chapter 1, "Overview"

Provides a general description of the Oracle Standard Management Pack.

Chapter 2, "Post-Installation Configuration"

Describes how to configure Performance Manager and TopSessions.

Chapter 3, "Introduction to Oracle Performance Manager"

Provides an overview of the Oracle Performance Manager application and its 
features.

Chapter 4, "Introduction to Oracle Index Tuning Wizard"

Provides an overview of the Oracle Index Tuning wizard.

Chapter 5, "Overview of the Change Management Applications"

Provides an overview of the Baseline Viewer, Create Baseline,  Compare Database 
Objects, and Change Manager applications and their features.

Chapter 6, "Using Change Manager"

Provides an overview of the Change Manager application.

Chapter 7, "Using Oracle TopSessions"

Provides an overview of the Oracle TopSessions application and its features.

Appendix A, "Troubleshooting Appendix"

Provides solutions to problems you may encounter while working with the 
Standard Management Pack.
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Conventions Used in This Guide
The following table  lists the conventions used in the guide.

This guide also assumes that you are familiar with the operation of Microsoft 
Windows NT. Refer to the Windows documentation for your system, if necessary. In 
general, this guide shows the directory names as they are used in UNIX; on an NT 
system, delineate directory names with a backslash (\).

To reduce wordiness and redundancy, menu and submenu choices are joined by 
arrows. For example, Collection=>Create refers to the Create Collection choice in 
the Collection menu.

Oracle Enterprise Manager Pack Information
The Oracle Enterprise Manager product family includes the following packs: Oracle 
Change Management Pack, Oracle Diagnostics Pack, Oracle Standard Management 
Pack, Oracle Tuning Pack, Oracle Management Pack for SAP R/3, and Oracle 
Management Pack for Oracle Applications. Each pack is fully integrated into the 
Oracle Enterprise Manager Console framework.

Oracle Change Management Pack

■ Includes Baseline Viewer, Change Manager, DB Alter, Create Baseline, Compare 
Database Objects, DB Propagate, DB Quick Change, Find Database Objects, and 
Plan Editor.

Convention Explanation

# The default superuser prompt.

% The default user prompt.

[Ctrl/C] Press the Ctrl key while you simultaneously press another key 
(in this case, C).

italics Italicized words indicate variables, such as a file or directory 
name.

$ORACLE_HOME Represents the directory where you installed Oracle Enterprise 
Manager components and the Oracle Standard Management 
Pack  applications.  The directory name may be different on your 
system.

otracexx The xx represents the version of the database for which you are 
collecting data; for example, otrace73 for the Oracle Server 
release 7.3.
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■ Tracks metadata changes in databases.

■ Eliminates errors and loss of data when upgrading databases to support new 
applications.

■ Analyzes the impact and complex dependencies associated with application 
change and automatically performs database upgrades.

■ Allows you to find the database objects that match a set of search criteria that 
you specify.

■ Initiates change safely with easy-to-use wizards that teach the systematic steps 
necessary to upgrade.

Oracle Diagnostics Pack

■ Includes Oracle Performance Manager, Oracle Capacity Planner, Oracle Trace 
Data Viewer, Oracle TopSessions charts, and Oracle Event Tests that are 
provided with the Oracle Diagnostics Pack.

■ Monitors, diagnoses, and maintains the health of databases, operating systems, 
and applications.  Both historical and real-time analysis are used to 
automatically avoid problems before they occur.

■ Provides powerful capacity planning features that enable users to easily plan 
and track future system resource requirements.

Oracle Standard Management Pack

■ Includes Baseline Viewer, Change Manager, Create Baseline, Compare Database 
Objects, Oracle Index Tuning Wizard, Oracle Performance Manager, and Oracle 
TopSessions charts.

■ Monitors and diagnoses problems, tunes high impact indexes, and tracks and 
compares changes in your Oracle environment.

Oracle Tuning Pack

■ Includes Oracle Auto-Analyze, Oracle SQL Analyze, Oracle Expert, Oracle 
Index Tuning Wizard, Oracle Tablespace Map, and Oracle Reorg Wizard.

■ Optimizes system performance by identifying and tuning major database and 
application bottlenecks such as inefficient SQL, poor data structures, and 
improper use of system resources.  

■ Discovers tuning opportunities and automatically generates the analysis and 
required changes to tune the system.  Inherent in the product are powerful 
teaching tools which train DBAs how to tune as they work.  
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■ Helps increase the productivity of developers and DBAs.

Oracle Management Pack for SAP R/3

■ Includes Oracle Performance Manager, Oracle Capacity Planner, and Oracle 
Event Tests that are specific to monitoring your SAP R/3 environment.

■ Monitors, diagnoses, and maintains the health of a SAP R/3 system. Both 
historical and real-time analysis are used to automatically avoid problems 
before they occur.

■ Provides powerful capacity planning features that enable users to easily plan 
and track future system resource requirements.

Oracle Management Pack for Oracle Applications

■ Includes Oracle Performance Manager, Oracle Capacity Planner, Concurrent 
Processing Tuning Assistant, and Oracle Applications Event Tests.

■ Enables you to monitor all aspects of your system, including databases and 
concurrent managers.

■ Enables the monitoring, diagnosing, and capacity planning of the Oracle 
Applications environment.

Related Publications
For further details about the information provided in this manual, see the following 
manuals in the Oracle Server documentation set:

■ Oracle9i Database New Features

■ Oracle9i Database Concepts

■ Oracle9i Database Administrator’s Guide

■ Oracle9i Database Performance Guide and Reference

■ Oracle9i Database Performance Methods

Oracle Enterprise Manager Documentation
The Getting Started with the Oracle Standard Management Pack manual is one of several 
Oracle Enterprise Manager documents.

Oracle Enterprise Manager base documentation



xvi

■ The Oracle Enterprise Manager Readme provides important notes regarding the 
online documentation, updates to the software, and other late-breaking 
information for Oracle Enterprise Manager and the Oracle Management Packs.

■ The Oracle Enterprise Manager Administrator’s Guide explains how to use Oracle 
Enterprise Manager, Oracle’s systems management console, common services, 
and integrated platform tool.

■ The Oracle Enterprise Manager Concepts Guide provides an overview of the 
Oracle Enterprise Manager.

■ The Oracle Enterprise Manager Configuration Guide explains how to configure 
Oracle Enterprise Manager.

■ The Oracle Enterprise Manager Messages Manual describes the Oracle Enterprise 
Manager error messages and methods for diagnosing the messages.

■ The Oracle Intelligent Agent User’s Guide provides configuration information and 
answers to crucial troubleshooting questions  pertaining to the Oracle 
Intelligent Agent.

■ The Oracle Enterprise Manager Event Test Reference Manual describes Oracle Event 
Tests which allow you to implement automatic problem detection and 
correction on concurrent managers, databases, listeners, nodes, and SAP R/3 
systems.

Oracle Management Pack Installation Documentation

■ The Oracle 9i Installation Guide Release 9.0.1 for UNIX Systems provides important 
information for installing the Oracle Enterprise Manager console and the 
management packs. This manual also contains information such as hardware 
and software requirements, installable components, and deinstallation 
procedures. The Oracle 9i Installation Guide Release 9.0.1 for UNIX Systems is 
located on the Oracle9i Online Generic Documentation CD-ROM, Release 1 
(9.0.1) or you can get a free download from the Oracle Documentation Center at 
docs.oracle.com. 

Oracle Change Management Pack documentation

■ The Getting Started with Oracle Change Management Pack manual provides an 
overview of the concepts and features of the Oracle Change Management Pack 
applications.
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Oracle Diagnostics Pack documentation

■ The Getting Started with the Oracle Diagnostics Pack provides an overview of the 
concepts and features of Oracle Performance Manager, Oracle Capacity 
Planner, Oracle Data Viewer, and the Oracle TopSessions charts.

Oracle Tuning Pack documentation

■ Database Tuning with the Oracle Tuning Pack provides an overview of the concepts 
and features of each of the applications included in the Oracle Tuning Pack. The 
applications include Oracle SQL Analyze, Oracle Expert, Oracle Index Tuning 
Wizard, Reorg Wizard, Tablespace Map, Outline Management, and the Outline 
Editor. A description of how these applications can work together to tune an 
Oracle database is also provided.

Oracle Management Pack for SAP/R3 Documentation

■ Oracle Management Pack for SAP R/3 Readme provides important notes regarding 
Oracle Management Pack for SAP R/3 online documentation, updates to the 
software, and other late-breaking information.

■ Getting Started with Oracle Management Pack for SAP R/3 provides an overview of 
the concepts and features of Oracle Performance Manager and Oracle Capacity 
Planner. It also describes Oracle Event Tests that are provided with the Oracle 
Management Pack for SAP/R3.

■ The Oracle Management Pack for SAP R/3 Installation Guide provides important 
information for installing the Oracle Management Pack for SAP R/3. This 
manual also contains information such as hardware and software requirements, 
installable components, and deinstallation procedures.

Oracle Management Pack for Oracle Applications Documentation

■ Getting Started with Oracle Management Pack for Oracle Applications provides an 
overview of the concepts and features of Oracle Performance Manager, Oracle 
Capacity Planner, and Concurrent Processing Tuning Assistant. It also describes 
Oracle Applications Event Tests and Jobs that are specific to monitoring your 
Oracle Applications environment.

Oracle Support
The Oracle MetaLink site provides access to information that will aid you in using 
Oracle products such as: hot topics, product reference, installation assistance 
materials, white papers, problem/solution articles, and more . To use this site you 
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must be a licensed Oracle user with an active support service contract. Contact your 
Oracle sales representative for more information.

Documentation Accessibility
Oracle’s goal is to make our products, services, and supporting documentation 
accessible to the disabled community with good usability. To that end, our 
documentation includes features that make information available to users of 
assistive technology. This documentation is available in HTML format, and contains 
markup to facilitate access by the disabled community. Standards will continue to 
evolve over time, and Oracle is actively engaged with other market-leading 
technology vendors to address technical obstacles so that our documentation can be 
accessible to all of our customers. For additional information, visit the Oracle 
Accessibility Program web site at http://www.oracle.com/accessibility/. 

How to Find Oracle Documentation Online
To download free release notes or installation documentation, please visit the Oracle 
Documentation Center at http://docs.oracle.com/.

Printed documentation is available for sale in the Oracle Store at 
http://oraclestore.oracle.com/.
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1
Overview

The Oracle Standard Management Pack is an optional set of applications that 
provide advanced tools that allow you to monitor and diagnose problems, tune 
high impact indexes, and track and compare changes in your Oracle9i environment.

The Oracle Standard Management Pack includes the following applications:

■ Oracle Performance Manager

Applies real-time, graphical Oracle and host monitoring through an extensive 
array of customized performance charts.

■ Oracle Index Tuning Wizard

Pro actively optimizes the indexes in your database environment.

■ Oracle Baseline Viewer

Lets you display baselines created using Create Baseline.

■ Oracle Change Manager

Gives you direct or indirect access to change management operations.

■ Oracle Create Baseline

Captures definitions of schema objects.

■  Oracle Compare Database Objects

Allows you to easily compare schemas or databases.

■ Oracle TopSessions Chart

Provides focused, performance diagnostics for Oracle sessions.

The following sections provide an overview of these applications.
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What’s New in Oracle Standard Management Pack for Release 9i
The following list provides the new features and enhancements to release 9i of the 
Oracle Standard Management Pack.

■ An enhanced real time diagnostics interface that builds on the new performance 
data organization and drilldowns for Performance Manager.

■ New organization of the Database Health overview diagnostics charts for 
easier performance assessment.

■ Integration of host operating system diagnostics data in the Database 
Health overview, providing a single monitoring point for databases and 
operating systems.

■ Drilldowns to diagnostics advice.

■ Automated generation and web publication of Performance Manager charts. 
This allows the administrator to set up status and performance reports that are 
periodically updated for access from a web server by other database 
administrators and system managers. This supports all services covered by 
Performance Manager.

■ New top activity diagnostics charts for finding and troubleshooting high impact 
sessions and SQL in Performance Manager.

■ New filtering capabilities providing complete flexibility in searching for 
high impact activity, such as high cost SQL by object or type.

■ New top details provide graphical performance data to help diagnose a 
problem session or SQL statement.

■ Direct Connect Performance Manager that allows database monitoring without 
the Agent and OMS.

■ Architectural enhancements for better performance and scalability for Change 
Manager. In this release there are performance improvements for Capture and 
Compare operations running against large schemas.

■ Extended coverage for Instance parameters in tracking applications. Change 
Manager is extended to capture and compare Oracle instance parameters. You 
can compare instance parameters between any combination of databases and 
baselines. This is valuable in diagnosing performance problems.

■ Browser-based implementation.
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Oracle Performance Manager
Oracle Performance Manager provides a system for capturing, filtering, and 
presenting performance data for both the database and the host operating system. 
Oracle Performance Manager offers:

■ Graphical, real-time monitoring

With Oracle Performance Manager, database and host operating system 
performance statistics are captured in real-time mode and can be viewed in 
various tables and charts and in two- and three-dimensional presentations.

■ Predefined charts

Oracle Performance Manager provides a large collection of predefined charts 
and tables organized into performance monitoring groups, including database 
contention, I/O, load, memory use, instance metrics, parallel server 
performance, and host operating system resource usage.

■ User-defined charts

Oracle Performance Manager can be used to graphically display any data 
accessible through SQL or through the data collection framework. The 
application allows you to create customized charts from user-defined scripts 
which then can be added to the Oracle Performance Manager navigator tree for 
easy access.

■ Customizable chart attributes and displays

With Oracle Performance Manager, chart properties and attributes can be 
customized to change the type of the presentation. The type of chart can be 
changed to bar, hierarchical, strip, pie, or table.

■ Chart drill down

Allows charts to be linked to other charts to gather detailed information.

■ Record and playback of charts

A user can capture a chart’s activity for analysis at a later date. Oracle 
Performance Manager allows charts to be recorded and played back at your 
convenience.

Oracle Index Tuning Wizard
The Oracle Index Tuning wizard quickly finds indexing problems that can slow 
down the performance of your Oracle8 database. You can use the Index Tuning 
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wizard to evaluate and optimize indexes for situations when, for example, SQL 
statement response time is slow.

The Index Tuning wizard considers your application type, for example, data 
warehousing, table, and SQL statements for tuning.

The Index Tuning wizard then implements the generated recommendations or 
saves the recommendations for later implementation. Each index recommendation 
generated contains detailed information on exactly what operation needs to be 
performed on the schema.

Oracle Change Manager
The Change Manager application is the change management central interface. In 
most cases, Change Manager gives you direct or indirect access to change 
management operations, such as creating baselines with Create Baseline and 
comparing database object definitions with Compare Database Objects.

Create Baseline
The Create Baseline application guides you through the process of capturing the 
definitions of a database (or a subset of a database) in a form useful to Compare 
Database Objects and other applications. Create Baseline lets you specify the set of 
database object definitions to capture, then captures those definitions in their 
current state.

Create Baseline can capture object definitions in both of the following forms:

■ A baseline. The baseline stores definitions in a form that Create Baseline can 
use. (A baseline is an object that contains a set of database definitions captured 
at a certain time.)

■ SQL DDL (optional). These SQL DDL statements can be used to create the 
definitions in a new database or as input to CASE tools that accept SQL DDL 
input.

The Baseline Viewer application lets you display baselines created using Create 
Baseline. Baseline Viewer also allows you to view a particular version of a baseline 
and to generate SQL statements for a baseline (if the statements were not generated 
already by Create Baseline when the baseline was created).
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Compare Database Objects
The Compare Database Objects application guides you through the steps of 
selecting two sets of object definitions and then comparing them. The object 
definitions can be selected from current databases or they can be selected from 
baselines created earlier with Compare Database Objects. If differences are found 
when the two sets of object definitions are compared, the Comparison Viewer 
allows you to view the differences between the corresponding object definitions.

Oracle TopSessions
The Oracle TopSessions chart provides a focused view of database activity by 
database session. Oracle TopSessions extracts and analyzes sample dynamic Oracle 
performance data by session, automatically determining the top Oracle users based 
on a specific selection criteria, such as memory, CPU usage, or file I/O activity.

Note: All the applications that make up the Oracle Standard 
Management Pack are members of other Oracle Enterprise 
Manager Packs. For this reason, you may find mention of other 
applications in the help, documentation, and user interfaces that 
make up the Oracle Standard Management Pack.
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Post-Installation Configuration

After you have installed the Standard Management Pack, configure the components 
listed in the following table:

Setting Up Performance Manager
The following setup tasks are required before you use Oracle Performance 
Manager:

■ Configure the Oracle Intelligent Agent to collect data

■ Optionally, enable disk statistics collection on Windows NT

The following setup tasks are required before you use Performance Manager:

■ Convert any user-defined charts you created with earlier versions of 
Performance Manager

■ If you plan to use Performance Manager in a Parallel Server environment, you 
may need to set up your server using Oracle-supplied SQL scripts.

The following sections describe each of these setup tasks in more detail.

Configuring Oracle Intelligent Agent to Collect Data
Performance Manager and Capacity Planner require the use of the Intelligent Agent 
data gathering service.  For monitoring operating system data, the Oracle Intelligent 
Agent must be installed on the same node as the operating system you are 

Components Where to Find the Information

Performance Manager Setting Up Performance Manager on page 2-1

Data Viewer Obtaining Trace Data for Use in Trace Data Viewer on page 2-4
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monitoring.  For monitoring other target types, such as databases, the Oracle 
Intelligent Agent can run on the same node as the target you are monitoring, or it 
can run on a different node, depending upon your configuration.

Refer to the Oracle Intelligent Agent User’s Guide for information on how to configure 
and start the Oracle Intelligent Agent.

Enabling Disk Statistics Collection on Windows NT
To collect disk statistics on Windows NT, enable them by typing: 

diskperf  -Y 

Disk statistics are enabled the next time the system is restarted. For more 
information about the DISKPERF tool, refer to the Microsoft Windows NT 
documentation.

Converting User-Defined Charts From Previous Releases of Performance Manager
If you created user-defined charts using Performance Manager release 1.5.0 or 
earlier and want to use them with the current Performance Manager release,  you 
must first convert them to release 1.6.0.

Performance Manager Release 1.6.0 user-defined charts are converted to the current 
release when you migrate your existing performance data to the Enterprise 
Manager Release 2.1 repository.

For more information, refer to the following sections.

Converting Performance Manager Release 1.5.0 User-Defined Charts 
To convert user-defined charts created using Performance Manager Release 1.5.0 or 
earlier:

1. Run vmmmig.exe. This executable creates a text file named vtmusr.txt in the 
$ORACLE_HOME\SYSMAN\ADMIN directory. This text file contains data 

Note: Enabling disk statistics is not required.  You can still 
monitor other operating system statistics with Performance 
Manager or Capacity Planner even if disk statistics are not enabled.

Note: Release 1.5.5 of Performance Manager did not include the 
functionality of user-defined charts.
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about the user-defined charts created using Performance Manager release 1.5.0 
or earlier. When you run vmmmig.exe, specify the user name, password, and 
service for the Enterprise Manager repository that contains the user-defined 
charts that you want to convert, for example:

vmmmig joseph/password@my_rep

Note that my_rep in the previous command line is the service name for the 
Enterprise Manager repository.

2. Run vmm2vtm.exe. This executable uses the data in the vtmusr.txt file to create 
user-defined charts in the repository that can be used with Performance 
Manager release 1.6.0. When you run vmm2vtm.exe, supply a user name, 
password, and target for the Enterprise Manager V2.x repository and the name 
of the target under which you want the user-defined charts stored for 
Performance Manager release 1.6.0, for example:

vmm2vtm.exe joseph/password@my_rep my_db

Note that my_rep in the previous command line is the target name of the 
Enterprise Manager V2.x repository and my_db is the name of the target service 
under which you want the user-defined charts stored. In other words, after the 
previous command is run, all the user-defined charts are converted and stored 
under the my_db service in the Performance Manager release 1.6.0 tree view.

If any error messages are generated when you run vmm2vtm.exe, edit the  
vtmusr.txt file based on the error messages. For example, the error messages 
may state that there is a problem with a chart or that a chart does not exist. 
Since the vtmusr.txt file contains a list of the charts, edit the file to remove any 
problematic charts.

Then, run vmm2vtm.exe again.

Converting Performance Manager Release 1.6.0 User-Defined Charts
If you created user-defined charts with Performance Manager Release 1.6.0, you can 
convert those charts for use with the current release of Performance Manager.  
User-defined charts created with Performance Manager 1.6.0 are converted when 
you create a new Enterprise Manager repository and migrate your existing 
performance data to the new repository.

For more information about creating a new Oracle Enterprise Manager repository 
and migrating your existing data, see the Oracle Enterprise Manager Configuration Guide.
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Using Performance Manager in a Parallel Server Environment
To use Performance Manager in a Parallel Server environment, two database 
instances must be started, otherwise Performance Manager does not treat the server 
as a Parallel Server.

There are two scenarios for using Performance Manager in an Oracle Parallel Server 
environment, and different configuration steps are required for each scenario.

The two scenarios and their configuration steps are:

1. If you are using Performance Manager to monitor an Oracle7 Parallel Server 
environment, do the following:

a. Ensure all instances are running.

b. Run the ops_gdl.sql script. This generates an appropriate ops_dbl.sql file. 
The ops_dbl.sql file shipped with the product is only an example. The 
actual contents of ops_dbl.sql depend on your database name, instance 
names, and the number of instances which exist.

c. Run the ops_mon.sql script, which runs ops_ctab.sql, ops_dbl.sql, ops_
pack.sql to create Performance Manager tables and views to fetch and 
display Oracle7 Parallel Server data in charts.

Oracle7 does not have global V$ (GV$) tables; these files install a set of 
PL/SQL procedures, database links, and O$ tables that are used by 
Performance Manager in the absence of GV$ tables.

2. If you are using Performance Manager to monitor an Oracle8 Parallel Server 
environment, you do not need to run any of the Parallel Server scripts. For 
example, if you use any release of Oracle that has GV$ tables (namely Oracle 
release 8.0 and later), you do not need to run these scripts.

For more information about Parallel Server scripts, see the Oracle Parallel Server 
Administrator’s Guide for Windows NT in the Parallel Server documentation set.

Obtaining Trace Data for Use in Trace Data Viewer
To obtain data to view, see the chapter, "Using Oracle Trace" in the Oracle9i Database 
Performance Guide and Reference for information about collecting Oracle Trace Data via 
the command line interface.
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3
Introduction to Oracle Performance

Manager

Oracle Performance Manager is an Oracle Enterprise Manager application that 
allows you to monitor the performance of the database and its related applications 
and operating systems in real time. It allows system and database administrators to 
monitor performance statistics for Oracle database servers, web servers, Oracle 
concurrent managers, operating systems, and other managed targets. Performance 
Manager also allows you to record statistics and play them back at a later time.

You can display these statistics in a number of formats including horizontal and 
vertical tables, strip charts, horizontal and vertical bar charts, and pie charts. You 
can also drill down for more detail on some predefined charts.

For most targets, Performance Manager integrates Event system thresholds with 
charts so that events and charts share common performance thresholds you can set 
from either monitoring point. This provides consistent monitoring of thresholds 
across Enterprise Manager and allows access to graphical and historical diagnostics 
information from the Event system. You can investigate event notifications by 
launching charts, historical data and diagnostic advice directly from the Event 
Viewer. Performance Manager charts incorporate event notification through chart 
threshold state indicators. Performance Manager threshold and event features are 
available for node and database data.

You can use activity diagnostic charts such as TopSessions for finding and 
troubleshooting high impact sessions. These charts provide graphical performance 
data to help you diagnose a problem session or SQL statement.
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Oracle Performance Manager uses the Intelligent Agent (Agent) to collect 
performance data. To monitor some types of data, you must install the Agent on the 
system (or systems) where you want to monitor data. See the Oracle Intelligent Agent 
User’s Guide for information on managing the Agent on a system.

If you are using Oracle Performance Manager to monitor database performance, the 
Agent can be installed on another system. See "Accessing Performance Data 
Through an Intermediate Host" on page 3-3 for more information on accessing data 
through an Agent on another system.

The types of performance data that Oracle Performance Manager can monitor on a 
system depends on the products that are installed. Table 3–1 shows the types of 
data (or targets) that Oracle Performance Manager can monitor when various 
Oracle products are installed. 

Note: In releases prior to 9i, the Agent data gathering service (also 
known as the Oracle Data Gatherer) was used to collect data for 
presentation in real-time performance monitoring utilities and 
historical data. The Intelligent Agent and the data gathering service 
were separate services that were started and stopped 
independently of each other.

With 9i, the data collection capabilities are integrated into the 9i 
Intelligent Agent. Therefore, there is no separate service that needs 
to be started. Furthermore, when you stop the 9i Intelligent Agent, 
the data gathering capabilities are disabled and not available.

Table 3–1 Data that Performance Manager Can Monitor when Various Oracle Products 
Are Installed 

Oracle 
Product

Oracle 
Concurrent 
Manager Data

Oracle 
Server 
Data

Operating 
System Data

SAP R/3 
System 
Data

Microsoft 
SQL 
Server 
Data

Diagnostics 
Pack

No Yes Yes No Yes

Management 
Pack for 
Oracle 
Applications

Yes No Yes No No
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If additional products from Oracle or other vendors are installed, Oracle 
Performance Manager may be able to monitor additional types of data not shown in 
Table 3–1.

Accessing Performance Data Through an Intermediate Host
Oracle Performance Manager relies on the Agent to monitor a target (such as a 
node, a database, or a concurrent manager). Usually, the collection of the data is 
done on the system where the target is located. However, for some types of targets 
Oracle Performance Manager can also monitor data on a system by using the Agent 
on another system (an intermediate host).

This intermediate host could be the client system where the Oracle Performance 
Manager is running, or any other system on the network on which the Agent is 
available.

There are three ways to set the location of the Agent.  The method you use depends 
on how you connect to the target.  Consider the following three scenarios:

■ You connect to a target that has been discovered using the Enterprise Manager 
console and you are running Oracle Performance Manager while connected to 
the Oracle Management Server.

Performance Manager attempts to connect to the Agent on the host where the 
target is located. If this connection fails or cannot be attempted because no 
preferred credentials have been set for the target, you can use the Connection 
Details dialog box to specify logon credentials for the target. This dialog box 

Management 
Pack for SAP 
R/3

No No Yes Yes No

Standard 
Management 
Pack (Oracle 
Standard 
Edition only)

No Yes Yes No Yes

Table 3–1 Data that Performance Manager Can Monitor when Various Oracle Products 
Are Installed (Cont.)

Oracle 
Product

Oracle 
Concurrent 
Manager Data

Oracle 
Server 
Data

Operating 
System Data

SAP R/3 
System 
Data

Microsoft 
SQL 
Server 
Data
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also contains a field to specify the location of the Agent that will be used to 
collect performance data.

■ You click the Add Service button in the toolbar panel and manually add the 
target to the navigator.

Performance Manager displays a Logon dialog box.  You can use the 
Connection Details dialog box to specify the location of the Agent that will be 
used to collect performance data.

■ You select a target in the Performance Manager navigator tree and choose Set 
Connection Details from the File menu.

Performance Manager displays the Logon dialog box for the selected target. Use 
the Connection Details dialog box to specify the location of the Agent that will 
be used to collect performance data.

Usage Scenarios for Oracle Performance Manager
Using Oracle Performance Manager, you can:

■ Monitor one or more targets concurrently.

■ View the monitored data in various chart formats, including strip (line), pie, 
bar, table, and hierarchical.

■ Set the refresh rate for a chart’s data.

■ View multiple charts concurrently for each monitored target.

■ View multiple charts in a single window.

■ Drill down from one chart to another related chart. Drill down to diagnostic 
advice.

■ Choose the collected data and data sources to display in a chart.

■ View threshold state indicators that provide immediate visual notification of 
performance status for specific targets. 

■ Print a chart.

■ Generate and publish an HTML report for a chart.

■ Display context-sensitive help for a chart, if help is available for the chart.

■ Play a recording of a chart, with fast-forward and pause features.

■ Create and modify user-defined charts.
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Starting Oracle Performance Manager
You can start Oracle Performance Manager from the Oracle Enterprise Manager 
console, from the UNIX command line, or from the Windows Start menu. 

Starting Oracle Performance Manager from the Console
You can start Oracle Performance Manager from the Oracle Enterprise Manager 
console in any of the following ways:

■ On the Oracle Enterprise Manager console, point to the Standard Management 
Pack drawer, then click Performance Manager.

■ On the Tools menu of the Oracle Enterprise Manager console, point to Standard 
Management Pack, then click Performance Manager.

■ Click the right mouse button on the target for which you want to start 
Performance Manager and then choose Performance Manager from the Related 
Tools menu item on the context menu.

Starting Oracle Performance Manager from the UNIX Command Line
To start Performance Manager from the UNIX command line, set default to the 
ORACLE_HOME/bin directory, then type the following command:

./oemapp pm

When you start Performance Manager from the UNIX command line, you are given 
a choice of logging in to the Oracle Management Server and running Performance 
Manager in Enterprise mode or Standalone mode.

See "Running Performance Manager in Enterprise Mode" on page 3-6 and "Running 
Performance Manager in Standalone Mode" on page 3-7 for more information about 
running Performance Manager in Enterprise mode and Standalone mode.

Note: When you start Oracle Performance Manager from the 
Oracle Enterprise Manager console, Oracle Performance Manager 
connects to the Oracle Management Server using the same 
credentials used to start the Oracle Enterprise Manager console.

Note: ORACLE_HOME represents the home directory in which 
the Standard Management Pack is installed.
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Starting Oracle Performance Manager from the Start Menu in Windows NT
On the Start menu of Windows NT, follow the path: Start=>Programs=>ORACLE_
HOME=>Standard Management Pack=>Performance Manager.

When you start Performance Manager from the Start menu, you are given a choice 
of logging in to the Oracle Management Server and running Performance Manager 
in Enterprise mode or Standalone mode.

Running Performance Manager in Enterprise Mode
To run Oracle Performance Manager in Enterprise mode:

1. Click Login to the Oracle Management Server.

2. Enter the appropriate connection information for your Oracle Management 
Server.

To select an alternate Management Server, click the Management Server button 
next to the Management Server drop-down list.  In the resulting dialog box, 
you can add another node that is running Oracle Management Server software. 
The Oracle Management Server and its associated repository must already 
exist.

For information on the fields in the Management Servers dialog box, click Help.

3. Click OK.

When Performance Manager is running in Enterprise mode and the navigator is 
first displayed with a target type folder expanded, the targets of that type that were 
discovered in the Enterprise Manager console are displayed. When you expand a 
target, Performance Manager attempts to connect to the target. When the target is a 
database and preferred credentials for the database have been saved in the Oracle 
Enterprise repository, Performance Manager attempts to connect to the database 

Note: ORACLE_HOME represents the home directory in which 
the Standard Management Pack is installed.

Note: If the repository was created using Enterprise Manager  
Release 2.1 or earlier, you must upgrade the repository or create a 
new repository.  For more information, see the Oracle Enterprise 
Manager Configuration Guide.
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using those credentials. Otherwise, the Oracle Database Logon dialog box prompts 
you for the logon information.

Running Performance Manager in Standalone Mode
To run Oracle Performance Manager in standalone mode (not connected to the 
Oracle Enterprise Manager repository), click Standalone, no repository connection, 
then click OK.

When Performance Manager is running in Standalone mode Performance Manager 
displays any targets that were added to the console in Standalone mode. You can 
add nodes or databases to the collection view for the current standalone mode 
session only. Click on the Add Service toolbar button after selecting the folder for 
the desired target type.

Using the Oracle Performance Manager Main Window
The primary component of the Oracle Performance Manager user interface is the 
main window (see Figure 3–1), which contains two panels. The navigator or tree 
panel appears on the left side of the main window and the property sheet panel 
appears on the right side. When you select an item in the navigator panel, the 
property sheet panel displays the properties of the selected item.

When you first start Oracle Performance Manager, the navigator panel displays the 
target type folders and the property sheet panel displays the Performance Manager 
welcome screen.

A vertical toolbar appears on the left side of the window and a menu bar appears 
across the top of the window.  For more information about the buttons in the 
toolbar and the commands available from the Performance Manager menus, choose 
Window from the Performance Manager Help menu.

In the navigator panel, the Network folder contains a folder for each target type. 
For example, when you have the Standard Management Pack installed, the target 
types are Nodes, Databases, and SQL Servers.  Not all target types may be available 
on all systems.

Note: Your recordings and user-defined charts will not be saved 
in Standalone mode. If you exit Performance Manager, you will not 
be able to play back any recordings or access these user-defined 
charts in future sessions. You will also not be able to save any chart 
settings or custom charts.
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In addition to the Network folders, the Recordings folder contains any recordings 
of chart data that exist. For more information about the Recordings folder, see 
"Recording Chart Data"  on page 3-21.

Figure 3–1 Oracle Performance Manager Main Window

Connecting to a Discovered Target in Enterprise Mode
Expand a target type folder to view the corresponding targets previously 
discovered through the Oracle Enterprise Manager console.

To connect to a discovered target, select the target in the navigator tree and click 
Connect to service in the Performance Manager toolbar, or click the plus sign (+) 
next to the target in the navigator. You can also connect to the target by double 
clicking on it in the navigator tree . You may be prompted with a Logon dialog box 
if credentials are required to connect to the target. For information on the fields in 
the Logon dialog box, click Help.



Viewing Performance Manager Charts

Introduction to Oracle Performance Manager 3-9

Manually Connecting to a Target
You can manually add additional targets that have not been discovered using the 
Enterprise Manager console.

To add and connect to a target manually:

1. Select the folder for the target type you are adding.

2. Click Add Service in the Performance Manager toolbar panel.

Performance Manager displays a Logon dialog box.

3. Fill in the fields in the Logon dialog box and click OK.  

For information on the fields in the Logon dialog box, click Help.

After you connect to a target, Performance Manager displays the classes of 
performance information you can monitor for the selected target. Expand a class to 
see the individual performance data charts available for the selected class.

Viewing Performance Manager Charts
You can display a chart using one of the following methods:

■ Select the chart in the navigator, and click the Show Chart button on the 
toolbar.

■ Select the chart in the navigator, and choose Show Chart from the Chart menu.

■ Select the chart in the navigator, which displays the chart’s property sheet. To 
start the chart with the selected property sheet options, click Show Chart on the 
property sheet.

■ Select a chart class, then select the chart in the Predefined Displays list and 
click Show Chart.

■ Select the chart in the navigator and click the right mouse button.  From the 
context menu, click Show Chart.

Note: When you add a target manually to the navigator tree using 
the Add Service button, you are adding that target for the current 
session of Performance Manager only.  You can begin collecting 
data for the target, but if you exit and restart Performance Manager, 
you will have to add the target again.
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Performance Manager displays each chart or chart group in its own window, which 
is separate from the main window. This window is called the Chart Display 
window.  For more information, see "Using the Chart Display Window"  on 
page 3-12.

Monitoring Multiple Targets Concurrently
You can view charts from multiple targets concurrently by connecting to the targets 
from the navigator tree and displaying charts.

Viewing Chart Groups
Some types of data include a chart group, which is two or more charts that are 
displayed within a single Chart Display window. You display a chart group the 
same way as you view any other chart (see "Viewing Performance Manager Charts" 
on page 3-9).

You can display a special chart group that contains the Overview Charts for a 
selected target:

1. Select a target in the Performance Manager navigator.

2. Click the Show Overview Charts button in the toolbar panel.

Performance Manager displays a chart group containing some key statistics 
most likely of interest to database administrators monitoring the selected target. 

Charts in a chart group are displayed within a single window. You perform actions, 
such as setting options and displaying drilldown charts, on one chart at a time 
within a chart group. The currently selected chart within a chart group window is 
identified by a highlighted title or a black box. For example, the Memory Faults 
chart is the currently selected chart in Figure 3–2.
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Figure 3–2 Identifying the Selected Chart In a Chart Group

Besides viewing the Overview Charts for a selected target, you can also view a chart 
group provided with a data class.  For example, you can select the Memory data 
class for a Windows NT node and display the Memory at a Glance chart group. Not 
all data classes provide chart groups, however.

Selecting Collected Data and Data Sources
For some charts, the chart’s property sheet allows you to select the collected data to 
display and the data sources for which the collected data should be displayed.

The collected data are the statistics that can be monitored and displayed in the 
chart. The data sources are the items from which Oracle Performance Manager is 
able to collect the data. For example, the data source of disk statistics may be disk1 
or disk2, and the data source of file statistics may be file1 or file2.

By clicking in the column next to the name of the collected data or the name of the 
data source in the chart property sheet, you can specify whether or not to monitor 
that collected data or data source and display it in the chart. 

When a green check mark appears in the column, Oracle Performance Manager will 
display that collected data or data source in the chart. If you click in the column 
again, the check mark goes away, which indicates that Oracle Performance Manager 
will not display that collected data or data source. You can toggle back and forth 
between monitoring and not monitoring all the collected data or data sources by 
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clicking in the column head. If the check mark is gray, it means Oracle Performance 
Manager will display the collected data or data source, and you are unable to 
change the selection of this data.

If the chart definition contains default data source or collected data attributes, then 
those items are preselected in the chart’s property sheet.

Using the Chart Display Window
When you display a chart, Oracle Performance Manager opens the Chart Display 
window.  The window contains its own toolbar and menu bar. For information 
about the Chart Display window, choose Window from the Chart Display window 
Help menu.

Selecting a Chart Format
To change the format of the chart, click on the Chart Format button in the Chart 
Display window toolbar and select the format in which you want to display the 
chart from the list that displays. 

For example, suppose a chart initially displays as a bar chart.  To see the data as a 
pie chart, choose Pie Chart from the list that displays when you click on the Chart 
Format button in the toolbar.  You can also display a chart in one of the additional 
formats:

■ Bar (vertical or horizontal orientation)

■ Strip (or line chart)

■ Table (vertical or horizontal orientation)

■ Hierarchical

You can also choose a chart format from the View menu in the Chart display 
window or right mouse click on a chart and select a chart type from the context 
menu. For more information about the buttons on the Chart Display window 
toolbar, see the Oracle Performance Manager online help.

Note: Depending upon the type of chart you are displaying, one 
or more of the chart formats may not be available.
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Setting the Chart Refresh Rate
By default, most charts are set to refresh every fifteen seconds but vary based on the 
chart.  That means that Performance Manager collects the data every fifteen seconds 
and then immediately refreshes (or redisplays) the chart using the new data.

To change the refresh rate for the current chart:

1. Click the Refresh Rate button in the Chart Display window toolbar.

Performance Manager displays the Refresh Rate dialog box.

2. Use the fields on the dialog box to set a new refresh rate for the current chart.

3. Click OK to close the dialog box and display the chart using the new refresh 
rate.

You can also choose Refresh Rate from the Collection menu to change the refresh 
rate.

Pausing and Restarting a Chart
By default, Performance Manager continues to collect performance data and update 
the current chart using the current refresh rate. 

To pause a chart so it stops redisplaying based on the refresh rate, click the Pause 
Chart button in the Chart Display toolbar.

To restart the chart, click the Resume Chart button in the Chart Display toolbar.

Selecting Chart Options
After you display a chart in the Chart Display window, you can still modify the 
collected data and data sources for the chart.  For more information about selecting 
the collected data and data sources before you display a chart, see "Selecting 
Collected Data and Data Sources" on page 3-11.

To set the chart options:

1. Click the Options button in the Chart Display toolbar.

Performance Manager displays the Options dialog box.

2. Use the Options dialog box to add or remove data items from the chart.

For more information on selecting data sources and selecting collected data, 
click Help.
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You can also access the Options dialog box by choosing Options from the Collection 
menu. 

Oracle Performance Manager also allows you to select filters to limit the data 
collected for a chart. However, not all charts provide filters. For charts that allow 
you to filter the chart data, you can select a limit to the number of data sources that 
are displayed. For example, if the data sources are the processes on an operating 
system, you can modify the chart to display only 10 processes, rather than all the 
processes. 

For example, to select a limit to the number of data sources that are displayed for 
the Pagefaults Per Session chart, do the following:

1. Highlight the Pagefaults Per Session chart in the navigator tree of the 
Performance Manager main window.

You can locate the chart by traversing the tree as follows: 
Network=>Nodes=><Name of Node>=>Process=>Pagefaults Per Process.

2. Click the Options tab in the Property Sheet panel.

3. Enter 10 in the Maximum Number of Data Sources to Display field.

The 10 data sources will be sorted by Page Faults per second, as shown in the 
Sort the data by drop-down list.

4. Click Show Chart.

Performance Manager displays the chart, but includes a maximum of 10 data 
sources.

Note: The Pagefaults Per Session chart in the Process class is 
available only when you are monitoring a Windows NT node. For a 
UNIX node, select the Process Info chart in the Process Data class 
as an example of a chart you can filter.

Note: The number of options available on the Options tab will 
vary, depending upon the chart you are modifying. Some charts 
offer more or fewer options than the Pagefaults Per Process chart 
discussed here.
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You can later change this setting after the chart is displayed:

1. In the Chart Display window for the Pagefaults Per Process chart, click the 
Options button in the toolbar.

2. In the Options tab, set the Maximum Number of Data Sources to Display back 
to 7.

3. Click OK.

These options can be useful for finding the top resource users. In the case where 
processes are the data sources and the data collected is memory usage and CPU 
usage, you can ask the Agent to limit the number of data sources to 10, and to sort 
by memory usage. Your chart would then show the 10 processes using the most 
memory. If you were to sort by CPU usage, you would get the 10 processes using 
the most CPU instead.

Some charts can also give different views of the data. If that feature is available, you 
will also be able to select a view of the data. An example of a data view may be the 
current rate per second or current rate per transaction for each piece of data 
collected in the chart.

Chart-Specific Commands
Some types of charts have their own unique commands. For example, you can select 
the Kill Session command when you are viewing the Lock Manager charts for 
Oracle database targets, or Turn SQL Trace On if you are viewing a Top Sessions 
chart. 

To see if a chart-specific command is available for a chart:

■ Click the right mouse button on an item name in the chart legend or a data item 
in the chart and click Drilldown on the context menu.

■ Click the Drilldown menu on the Chart Display window menu bar.

Drilling Down from One Chart to Another
Some charts have drill-down charts associated with them. To see if any drill-down 
charts are available for the current chart, do one of the following:

■ Click the right mouse button on an item name in the chart legend or a data item 
in the chart and click Drilldown on the context menu.

■ Click the Drilldown menu on the Chart Display window menu bar.

■ Click on the Chart Status button.
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In all cases, Performance Manager displays any drill-down charts associated with 
that chart item as menu options on the Drilldown menu. If a list of drill-down chart 
names is not displayed, no drill-down charts are associated with that item.

Using the Chart Status Button
You can use the Chart Status button located in the upper right corner of a chart to 
perform one of several tasks. When you click on the button, menu items appear 
based on the context of the chart as seen in Figure 3–3.

Figure 3–3 Chart Status Button

■ View the threshold status of chart metric(s)

The Chart Status button displays the current status of thresholds for metrics in 
the chart. If an indicator flag is present, at least one of the metrics on the chart 
has thresholds defined. The most severe threshold displays on the button. A 
green flag indicates that no metrics have crossed a threshold, a yellow flag 
indicates that at least one metric has crossed a warning threshold, and a red flag 
indicates that at least one metric has crossed a critical threshold. When you 
press the Chart Status button, you can view the status of individual metrics 
within the chart. If several metrics have crossed warning or critical thresholds, 

Note: If you have trouble selecting a particular data item when 
you try to drill down for related data, pause the chart or reduce the 
refresh rate. For more information, see "Pausing and Restarting a 
Chart" on page 3-13.
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the menu items are sorted according to the severity, with the indicators for the 
most severe items on top and the less severe on the bottom.

■ Display advice on a data item

When you choose Advice from the Chart Status button, Performance Manager 
displays an information window that provides information about the currently 
selected data item along with guidelines for solving existing problems, or 
suggestions about other charts to view for further diagnosis, as seen in 
Figure 3–4.

Figure 3–4 Viewing Advice from the Chart Status Button



Using the Chart Display Window

3-18 Getting Started with the Oracle Standard Management Pack

■ Drill down to a chart

After you select a data item, you can choose to drill down to one of the charts 
displayed in the list or invoke tools like SQL Analyze.

■ Set or reset thresholds for a chart or an event

You can set chart-only thresholds for a data item or you can reset the chart-only 
threshold to its default value. You can choose to set or edit the threshold for the 
value in the chart only, or you can edit or register an event threshold for the 
data item. For more information, see "Registering Events in Performance 
Manager" on page 3-31.

■ Edit a threshold association

You can edit a threshold association for a metric by selecting Edit Threshold 
Association from the Chart Status button and choosing an event from the dialog 
box that appears. For more information, see "Editing Threshold Associations" 
on page 3-35.

■ Refresh thresholds

To view Event System changes made while a Performance Manager chart is 
visible, choose Refresh Thresholds from the Chart Status button menu on the 
Performance Manager chart. For more information, see "Refreshing Thresholds" 
on page 3-34.

Displaying Alternate Chart Orientations
You can display bar charts and tables with either a horizontal or vertical orientation.

To change the orientation of the bar chart or table, click the button associated with 
the orientation that you want.

Note: In addition to accessing help topics for individual metrics 
and events through the Advice function, you can view the full 
documentation set for all types of metrics and events 
independently through your web browser. For more information 
see "Viewing Metric and Event Documentation Through a Browser"  
on page 3-37.
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Sorting Data in a Table Chart
When a chart is displaying data in table format, the sort order of the column data 
can be changed by clicking the column headers in the table. The first click on a 
column header sorts the data in ascending order, and a second click sorts the data in 
descending order.

Changing the sort order in the chart table does not affect the data’s sort order on the 
server. To change the sort order of the data on the server, use the Options page. For 
more information, see "Selecting Chart Options" on page 3-13.

Saving Your Changes to a Chart
If you are working in repository mode and you make modifications to a chart (for 
example, if you change the format, orientation, or sorting order of a chart), you can 
save your changes in one of two ways:

■ Click Save on the Chart Display File menu.

Performance Manager saves your changes using the same name as the original 
chart. When you display the chart again, your changes will appear in the Chart 
Display window.

To later remove your changes and display the predefined chart using its 
original settings, click Remove Chart on the Chart menu.

■ Click Save As on the Chart Display File menu.

Performance Manager displays the Save Custom Chart dialog box. Use this 
dialog box to enter a name for the custom chart and to indicate whether you 
want to create a similar chart for other targets of the same type.  For 
information about the fields on the Save Custom Chart dialog box, click Help.

Click OK in the Save Custom Chart dialog box to save the custom chart using 
the name you provided.  Performance Manager saves the chart in the Custom 
Charts folder for the selected target.

To delete a custom chart from the Custom Charts folder, select the chart and 
click Remove Chart on the Chart menu.

Note: You can remove the changes you saved to a predefined 
chart, but you cannot delete the original predefined chart.
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Obtaining Help for a Class, Chart, or Data Item
To get help on a class or chart:

1. Select the class or chart in the main window navigator.

2. From the Help menu,  choose Selected Item.

If help is available for the selected chart, Performance Manager displays a 
message box or a help topic window describing the chart data.

To get help on a data item:

1. Select a chart.

2. In the Property Sheet panel, select a data item and choose Selected Item from 
the Help menu.

Printing a Chart
To print a chart, click the Print Screen button on the Display Chart window toolbar.

The size of the chart on the screen determines the size of the chart in the chart 
printout. For example, when you print a chart that is 5 inches high and 7 inches 
wide on your screen, the chart will be 5 inches high and 7 inches wide in the 
printout.

Generating a Report for a Chart
To generate an HTML report for a chart:

1. Click the Report Chart button while the chart is displayed.

Performance Manager displays a dialog box that tells you the name of the 
HTML file used to display the report and where the file will be saved. 

2. Make a note of the file name and location.

3. Click Yes to preview the chart in your Web browser, or click No if you do not 
want to preview the report.

Note: You can delete custom charts, but you cannot delete 
predefined charts.

Note: Help is not available for all objects.
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You can view the report later using a Web browser, or—if you have experience with 
Web publishing tools and techniques—you can share the report with your 
co-workers by publishing the HTML file and its associated graphic files on a Web 
server. 

Recording Chart Data
Oracle Performance Manager allows you to record the data being monitored in a 
chart. After a recording is complete, you can play it back. During playback, you can 
pause and fast forward the recording, if you wish.

Chart recordings are saved under the Recordings folder and on the Recordings tab 
of the right pane of the Performance Manager main window when a recorded chart 
is selected. The Recordings tab is added to a chart’s property sheet after you record 
the chart.

You can manage chart recordings in the Recordings folder without connecting to 
the target from which a chart was recorded. If you are already connected to a target, 
you can see a chart’s recordings by selecting the Recordings tab in that chart’s 
Detail property sheet.

Starting a Recording
You start a recording by performing one of the following steps:

■ With a chart highlighted in the navigator tree of the Performance Manager main 
window, click Record Chart on the chart’s property sheet.

■ With a chart displayed in the Chart Display window, click Start Recording in 
the Chart Display window toolbar.

■ With a chart displayed in the Chart Display window, click 
File=>Recording=>Start Recording.

Oracle Performance Manager displays the Recording Parameters dialog box.  For 
more information on the fields in the Recording Parameters dialog box, click Help.

Stopping a Recording
To stop recording a chart, do one of the following:

■ To stop recording the current chart, click the Stop Recording button in the 
Chart Display window toolbar.
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■ To stop all recordings at one time, choose Stop All Recordings from the 
Performance Manager main window Recordings menu.

■ To stop a recording from the Recordings folder, expand the Recordings folder 
in the Performance Manager main window and navigate to the chart.  Select the 
chart and click Stop Recording on the chart’s property sheet.

■ With a chart displayed in the Chart Display window, click 
File=>Recording=>Stop Recording.

Playing a Recording

To play a recording, do the following in the Performance Manager main window:

1. Navigate to the Recordings folder.

2. Select the chart you want to play in the navigator tree.

3. In the corresponding property sheet, select the recording from the list of 
recordings for the selected chart, and click Play Recording (or on the 
Recordings menu click Play Recording).

4. In the Chart Display window toolbar, click Start Playback.

The Stop Playback, Pause Playback, and Fast Forward buttons become 
available in the playback window (Figure 3–5).  When the playback is complete, 
the Reset Playback button becomes available.

Figure 3–5 Chart Playback Buttons in the Chart Display Window

Note: Before you can play a recording, you must stop the 
recording.  For more information, see "Stopping a Recording" on 
page 3-21.
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Removing a Recording
To remove a recording:

1. Navigate to the Recordings folder or the Recordings tab on the chart’s Detail 
page.

2. Select the recording you want to remove.

3. From the Recordings menu, click Remove Recording.

Creating a User-Defined Chart
In addition to predefined charts, you can define your own charts for database 
targets based on user-defined scripts. By defining your own charts, you can take a 
snapshot of data at any given interval. After successful evaluation of the script, you 
can define the operations to be performed on the data.

To define a new chart:

1. Expand the Databases folder in the navigator tree.

2. Expand the database for which you want to define a user-defined chart.

3. Select the User-Defined Charts folder.

4. Click Create User-Defined Chart in the toolbar.

The resulting New Chart property sheet includes the SQL Script Command 
page and the Data Items page.

5. On the SQL Script Command page, enter a SQL script that will be used to 
gather statistics for the chart you are defining.

6. Click Evaluate.

Performance Manager evaluates the SQL script. If the script is valid, 
Performance Manager displays the Data Items page.

7. Use the Data Items page to customize how the resulting data from the script 
entered on the SQL Script Command page will be displayed in chart form. 

Note: The Performance Manager online help includes an example 
of creating a user-defined chart. Search for Example in the online 
help index.
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You can remove columns and change the names of the columns. You can also 
define new columns with data calculated from existing columns. For more 
information, see "Modifying the Data Items for a User-Defined Chart" on 
page 3-24.

Modifying an Existing User-Defined Chart
To modify an existing chart you perform the same steps as outlined in "Creating a 
User-Defined Chart" on page 3-23. The only exception is that the chart label is 
already defined.

To modify an existing chart:

1. Expand the Databases folder in the navigator tree.

2. Expand the database for which you want to modify a user-defined chart.

3. Select the User-Defined Charts folder.

4. Click the name of the chart you want to modify.

On the SQL Script Command page, you can modify the script used to gather 
statistics for the chart. On the Data Items page, you can remove, add, or modify 
the data items associated with the chart. For more information, see "Modifying 
the Data Items for a User-Defined Chart" on page 3-24.

Modifying the Data Items for a User-Defined Chart
When you select a user-defined chart and then display the Data Items page, you can 
modify the data items for the chart as follows:

■ Select a data item and click Set Data Source.

A key icon appears next to the data item you designate as the data source.  The 
data source is the object about which Performance Manager is able to collect the 
data. You must designate one of the data items as the source for the 
user-defined chart. To designate a data item as the data source, highlight the 
data item you want as the data source and click this button. By default, the first 
data item is set as the data source.

Note: To add or modify data items to user-defined charts, you 
must use the Agent release 8.1.6. or later.
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■ Select a data item and click Remove.

Performance Manager removes the data item from the Data Items page.

■ Select a data item and click Modify or click Add to add a new data item to the 
user-defined chart.

Performance Manager displays the Add/Modify Chart Columns dialog box. For 
more information about this dialog, click Help. The Oracle Performance Manager 
Help provides details on the functions and operations available. The Help also 
provides an example of creating a user-defined chart.

Copying a User-Defined Chart
You can copy user-defined charts from one target to another or within the same 
serve by using the Create Like option. To copy a user-defined chart: 

1. In the navigator tree, select the user-defined chart you want to copy.   

2. From the Charts menu, click User-Defined Charts=>Create Like. 

Performance Manager displays the Create Like User-Defined Chart dialog box. 

3. Type a label for the new chart in the Chart Label field. 

Note that chart labels must be unique within a target. 

4. In the Service drop-down list, select the target service for the new chart. 

5. Click OK. 

In the Create Like User-Defined Chart dialog box, you can choose the SQL Script 
Command or Data Items page to view the attributes of the chart you are copying. 
However, you cannot change the values of the attributes. Once the chart has been 
copied, you can select the new chart in the navigator tree and make any desired 
adjustments.

Converting Old Performance Manager User-Defined Charts
If you created user-defined charts using Oracle Performance release 1.5.0 or earlier 
(the Windows versions of Oracle Performance Manager), you can convert these 

Note: To add or modify data items to user-defined charts, you 
must use the Agent release 8.1.6 or later.
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user-defined charts so that they can be used with Oracle Performance Manager 
release 2.1. See "Converting User-Defined Charts From Previous Releases of 
Performance Manager" on page 2-2 for information on how to perform the 
conversion.

Chart Display Window Menu Shortcut Keys
Table 3–2 lists the Chart Display Window menu and submenu items along with 
their corresponding shortcut keys.

Table 3–2 Chart Display Window Shortcut Keys

Task Shortcut Key

Print Screen . . . Control+P

Report Chart. . . Control+R

Start Recording Control+K

Stop Recording Control+J

Start Playback Control+Q

Stop Playback Control+Y

Pause Playback Control+W

Fast Forward Control+F

Reset Playback Control+B

Save Control+S

Save As Control+A

Close Alt+F4

Pause/Resume Chart Control+Q

Refresh Rate . . . Control+E

Options Control+O

Historical Data Control+D

Using Help Control+Shift+U

Help on Item Control+Shift+H

Contents Control+H

Search . . . Control+Shift+S
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Working With Events and Thresholds in Performance Manager
You can create and edit threshold values from both the Oracle Enterprise Manager 
console and Performance Manager.

From Performance Manager, you can create and edit a Chart-only threshold, create 
and register an event, reset a Chart-only threshold, or edit a registered event. From 
the Enterprise Manager console, you can create, edit or deregister an Enterprise 
Manager event but you cannot edit or view Chart-only thresholds.

You can set thresholds on data items by using event tests or by setting a threshold 
for a data item in a chart (Chart-only threshold) using the Set Chart-only Threshold 
dialog box seen in Figure 3–6. When you monitor a chart that contains a data item 
that supports a threshold established for an event, you can edit the parameters for 
that event by choosing Set Threshold from the Chart Status button.

When you create events from Performance Manager, the event is initialized with 
the context defined by the Performance Manager chart. You can only modify the 
event tests in an event if the event was registered using the Oracle 9i Agent.

If a data item supports the concept of an event, the chart displays a visible indicator 
(a flag) based on thresholds stored in the repository for that data item. If the data 
item does not support the concept of an event, you cannot establish a chart-only 
threshold for the data item. Every metric-based event test can have a warning and a 
critical threshold value. The flag indicators on a chart specify whether a threshold 
value has crossed a warning or critical threshold. The flag that appears on the Chart 
Status button in a chart displays the most serious state of any contained metric 
thresholds, and the metrics that appear when you click on the Chart Status button 
are sorted with the most serious indicators displayed first in the list.

Window F1

Note: The Performance Manager threshold and event features 
described in this section are available only for node and database 
data.

Table 3–2 Chart Display Window Shortcut Keys

Task Shortcut Key
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Figure 3–6 Set Chart-only Threshold dialog box

Threshold values may be derived from one of three sources:

■ A default value for some metrics that is added to the repository at the time of 
product installation.

■ Chart-only thresholds, which are warning and critical threshold values for a 
specific metric, target, target type and instance.

■ An event test derived threshold, which can be shared among administrators 
depending on the access rights of the user and the event containing the event 
test. When you set a threshold on a data item associated with an existing event, 
the thresholds displayed in that chart correspond to the thresholds set for the 
event test.

The threshold types listed above apply to metrics in a specific order of precedence:

■ If you have Event System access and access to an event containing a metric, the 
threshold values for the metric are defined by the Event Test and override any 
Chart-only or default threshold values.

■ If you have established a Chart-only threshold for a metric, the threshold values 
you establish are valid and supersede any default values that may exist.
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■ If neither of the previous two scenarios exist and a default threshold is defined 
in the repository for the metric, the default value defines the warning and 
critical thresholds for this metric, regardless of target or data source.

Threshold values are stored in the Oracle Management Server respository and are 
updated whenever the user sets or edits a Chart-only threshold or when Event 
registration changes occur. Chart-only thresholds are removed from the repository 
when you invoke Reset Threshold or when the Administrator is removed from the 
system. If you create a Chart-only threshold that is later overridden by the 
registration of an event, the Chart-only threshold remains in the repository. If the 
association between the metric and the event is later broken, the Chart-only 
threshold is restored.

To set or edit thresholds in Performance Manger:

1. Click the Chart Status button in the upper right corner of the chart below the 
menu bar.

2. Select the data item for which you want to set a threshold and then choose Set 
Thresholds from the context menu.

If there is more than one data source displayed in a chart when you select Set 
Thresholds, Performance Manager displays the Select Data Source dialog box 
where you must choose a single data source for which to set a threshold. When 
you create or edit a chart-only threshold or create a new event, you must choose 
a single data source before setting thresholds.

3. To set or modify a Chart-Only threshold, select Set Chart-Only Threshold at 
the bottom of the window. To register an event, select Register Event.

4. To set or modify a Chart-Only threshold, add or modify the values in the 
Warning Threshold and Critical Threshold fields. If default warning or critical 
threshold values are defined for the metric, the input fields will contain these 
values.

To register or modify an event, select Register Event and then complete the 
fields in the General, Test, Parameters, Schedule, Access and Fixit Jobs pages of 
the event property sheet. If you are using a pre-9i Agent and you modify an 

Note: If you do  not have permission to access the Enterprise 
Manager Event System, the option of registering an event from the 
dialog box is not present.
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event that has been registered, those changes are not used by the registered 
event.

Triggered Events and Thresholds
Events and thresholds often poll at different intervals. For example, events may be 
polled at intervals of minutes or even hours, while thresholds may be sampled in 
seconds. The result is that you could see a metric cross a threshold in a chart but not 
be notified of an event simultaneously. If the problem were caused by a spike, the 
threshold may be crossed in the chart with a sampling occurrence measured in 
seconds, but not trigger an event because the metric is sampled in minutes or hours, 
meaning the event is never triggered at all.

Additionally, events can include the concept of occurrences. Occurrences prevent 
notification for erratic or one-time instances of a threshold being crossed. If an event 
has a number of occurrences associated with a test, you may see the threshold 
crossed in a chart but never see the corresponding event triggered.

Events Registered for Multiple Targets
If you attempt to modify a threshold that has an associated event test registered for 
multiple targets, a warning displays indicating that the change you make will affect 
the event test for multiple targets and that if you want to use different thresholds 
for each target, you must create separate events. If you continue with the change, 
the existing event is deregistered for all targets and re-registered for all targets with 
the new threshold.

Metrics with Multiple Events and Different Thresholds
When you display a chart for a data item for which there are multiple event tests, a 
message is displayed indicating that there are multiple tests for the same metric. To 
show a threshold for the chart, you must select which event test to associate with 
the metric. If you then modify the associated event test or the metric in the chart, 
the thresholds are synchronized. Other tests of the metric are not affected by 
changes to the threshold in a chart.

If another user de-registers the associated event test and then you display a chart 
with that metric, a warning displays indicating that the previously associated event 
test no longer exists. If only a single event test remains for the metric, the message 
indicates that the remaining event is now associated with the metric. If more than 
one event remains, the message indicates that you must select a new event to 
associate with the metric.
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If you add a new event test for a metric where a single chart-only threshold already 
exists, the thresholds associated with the previous test will not be used during 
monitoring.

Event Permissions
If you display a chart for which you have read-only permission for the 
corresponding event, you cannot modify the thresholds for that chart. You receive a 
read-only view of the event indicating that if you wish to change the thresholds 
associated with the data item, you must be granted appropriate access to the event 
system.

Registering Events in Performance Manager
You can register events from within Performance Manager through the Chart Status 
button on a chart containing the data item for which you want to register an event. 

Registering events through Performance Manager is procedurally identical to 
registering events through the Enterprise Manager console.

To create or edit events in Performance Manager:

1. Click on the Chart Status button in the upper right corner of the chart.

2. Select the data item and then choose Set Threshold from the context menu.

If there is more than one data source displayed in a chart when you select Set 
Threshold, Performance Manager displays the Select Data Source dialog box 
where you must choose a single data source for which to set a threshold. When 
you create or edit a Chart-only threshold or create a new event, you must 
choose a single data source before setting thresholds.

3. Select Register Event at the bottom of the dialog box.

4. Complete or modify the fields in the General, Test, Parameters, and Permissions 
pages of the property sheet to create a new event. If you are using a pre-9i 
Agent and you modify an event that has been registered, those changes are not 
used by the registered event.

Note: Super-users  who set up permissions on an event should 
consider the effect on non-privileged administrators who will be 
unable to modify the thresholds.
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When you use a pre-9i Agent, the property sheet for creating a new event is similar 
to the property sheet for modifying an event. Some fields are editable while others 
are not. If you are using a 9i Agent, you can modify many more fields.

You can use several predefined event tests that have been installed with Oracle 
Enterprise Manager. 

About Oracle 9i and Pre-9i Agents
If you attempt to register a 9i event with a pre-9i Agent, you will receive an error 
message indicating that you cannot register the event. You can use only a 9i Agent 
to register 9i events. 

If there exists both a 9i and pre-9i version of the same event, then the Oracle 
Management Server will determine which to use depending on the Agent version. 
For example, if there is a 9i Agent, the Agent will request registration using the 9i 
version of the event. If the Agent is pre-9i, then it will use the pre-9i version.

If you have migrated from a pre-9i Agent, then an existing event will not 
automatically use the 9i counterpart. To use the 9i test and access thresholds in the 
repository, you must deregister the pre-9i event and register the 9i event using the 
9i Agent.

Viewing Thresholds
If a Performance Manager chart is displaying metrics that have multiple data 
sources, you can display the View Thresholds dialog box to view all threshold 
indicators. The View Thresholds dialog box is accessible from the Chart Status 
button.

The View Thresholds dialog box displays the current threshold status of each data 
item and its corresponding data source. You can view the status for each 
metric/data source pair using flags to indicate whether the value of the data item 
has passed its warning or critical threshold. If a data item has no threshold set, the 
column containing that data item is left blank.

When you display the View Thresholds dialog box, the current data item and 
threshold values are captured in a dataset and the status of each threshold is 
displayed in the table. A timestamp of the dataset appears in the bottom left corner 
of the View Thresholds dialog box.

If you change a threshold value for a data item while the View Thresholds dialog 
box remains open, the new threshold value is compared against the dataset created 
at the time you displayed the dialog box, not against the current value of the data 
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item in real time. To refresh the statuses in the View Threshold dialog box, close and 
redisplay it.

You can add or change threshold values by clicking the Chart Status button on the 
View Thresholds dialog box and choosing Set Threshold from the context menu.

To view thresholds:

1. Click the Chart Status button for the chart containing the data item for which 
you want information and select View thresholds from the context menu.

The View Thresholds dialog box appears, displaying the status of any 
thresholds set for each of the data items and data sources in the chart. The 
status for a threshold is indicated by the flag that appears in the column for the 
data item and data source.

■ A green flag indicates the value for the data item has not crossed a  
threshold.

■ A yellow flag indicates the value for the data item is at or has passed the 
warning threshold.

■ A red flag indicates the value for the data item is at or has passed the 
critical threshold.

If no threshold is set for a data item, the status for that metric is left blank.

The threshold statuses that appear in the View Thresholds dialog box are 
derived from dataset values gathered at the time you display the View 
Thresholds dialog box. The date and time of the dataset appears at the bottom 
of the dialog box. The View Thresholds dialog box is not updated when the 
Performance Manager chart is refreshed.

From the View Thresholds dialog box, you can set thresholds or reset and edit 
associations for a specific cell if thresholds are set.

You can set or edit a threshold for a metric from the View Thresholds dialog box by 
clicking the Chart Status button and selecting Set Thresholds from the context 
menu. For more information about setting thresholds, see "Working With Events 
and Thresholds in Performance Manager" on page 3-27.
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Resetting Thresholds
You can reset Chart-only thresholds through the Chart Status button on a chart. If 
you reset a Chart-only threshold for a data item, the current threshold is deleted 
and is reset to its default value. If the data item has no default value, the threshold 
is simply deleted and no value is assigned as a threshold.

If you select Reset Threshold for a data item with an assigned event, a message box 
displays stating that you must deregister or edit the event from within the 
Enterprise Manager console.

To reset a threshold:

1. From the chart, click on the Chart Status button and select the metric and data 
source for which you want to reset a threshold.

2. From the context menu, choose Reset Threshold. When you select Reset 
Threshold, the current data item is reset to its default value. If the data item has 
no default threshold value, the threshold is eliminated.

A confirmation dialog box appears, verifying that you are about to reset the 
threshold for the current metric. Click the OK button to confirm.

If no threshold exists for the metric, an error dialog box displays informing you 
that the threshold cannot be reset because no threshold exists for the metric.

If you attempt to reset a threshold associated with a registered event, an error 
message dialog box displays. You cannot deregister an event from within 
Performance Manager because the event associated with a metric may have several 
other targets and tests. You can instead edit the event from within Performance 
Manager by choosing Set Threshold (for 9i targets) to remove or modify the event.

Refreshing Thresholds
A chart may not reflect an event that is registered while the related chart is open 
because the information for the metric in the chart related to the event has not been 
read from the repository. A chart does not automatically reflect the effect of event 

Note: If you add or change the value of a threshold for a data 
item, the status flag for the data item on the currently displayed 
View Thresholds dialog box is updated based on the values stored 
in the dataset at the time the View Thresholds dialog box was 
displayed. To update all the status flags in the current chart, close 
the View Thresholds dialog box and redisplay it.
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system changes. When you select Refresh Thresholds from the Chart Status button, 
Performance Manager updates the chart with the new data from the threshold 
repository and updates the chart threshold indicators.

When Event Registration or Permission changes effect the threshold respository, 
Performance Manager users are notified of these changes in a dialog box when the 
threshold data for the metric is next read from the repository. The following actions 
are conveyed to the Performance Manager user when a chart is opened, thresholds 
are refreshed for a chart, or thresholds are edited:

■ An event test associated with a metric has been deregistered.

■ A Chart-only threshold is overridden by the registration of an event test by 
another user.

■ An event test associated with a metric has failed registration.

■ Access to an event containing an event test associated with a metric has been 
removed.

■ An event test associated with an event has been removed from the event or the 
instance has been modified.

■ An event test associated with a metric has failed event modification.

To refresh thresholds, choose Refresh Thresholds from the Chart Status button on 
the Performance Manager chart.

Editing Threshold Associations
There may be circumstances when a user has permission to view several events that 
contain the same event test. When viewing a chart, you must decide which event 
will be associated with the metric in the chart. You can invoke Edit Threshold 
Association to change this association.

The Edit Threshold Association menu item has no application for data items with 
less than two events assigned to it. If you select Edit Threshold Association in such 
a case, a message box appears informing you that the threshold association cannot 
be changed because a threshold association for the metric does not exist or there is 
only one registered event test.

You cannot change the association for Chart-only thresholds because each user has 
his own pool of Chart-only thresholds and duplicates are not supported.

To edit threshold associations:
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1. Click the Chart Status button in the current chart and select the metric for which 
you want to edit the threshold association, and then choose Edit Threshold 
Association from the context menu.

2. When applicable, select the data source from the Select Data Source dialog box 
and click OK.

3. Select the event threshold you want to assign to the data item in the list that 
appears in the Associate Metric with Event Test dialog box.

4. Click the OK button at the bottom of the Associate Metric with Event Test 
dialog box.

To edit threshold associations:

1. Click the Chart Status button in the current chart and select the metric for 
which you want to edit the threshold association and then choose Edit 
Threshold Association from the context menu.

2. When applicable, select the data source from the Select Data Source dialog box 
and click OK.

3. Select the event threshold you want to assign to the data item in the list that 
appears in the Associate Metric with Event Test dialog box.

4. Click on the OK button at the bottom of the Associate Metric with Event Test 
dialog box.

Running Performance Manager in a Browser
You can run Oracle Performance Manager in a browser and use a significant subset 
of the features of the full product, including basic monitoring features and event 
integration. Browser support includes basic monitoring features and event 
integration if you are using a version 9i Agent (or later).

The following features are available when running Performance Manager in a 
browser:

Note: If you attempt to set a threshold association when the 
metric is not associated with an event test or you only have 
permission to view one registered event test for the specified target 
and data source, an error dialog box appears informing you that the 
association cannot be changed.
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■ Show database chart

■ Show node chart

■ Drilldowns

■ Help

■ Quick Tour

■ Print Screen from charts

■ Report Chart from charts

■ Pause/Resume charts

■ Set Refresh Rate

■ Set Options

■ Setting Chart-only thresholds    

■ Event Registration  

The following features are not available while running Performance Manager in a 
browser:

■ Recordings

■ Historical collection drilldowns

■ Custom Charts

■ Saved chart attributes

■ User-defined charts

■ Direct Connect

■ Standalone mode

■ SQL Analyze

■ Threshold status

Viewing Metric and Event Documentation Through a Browser
You can view specific information about metrics, events, charts and classes in 
Performance Manager through the Advice function on the Chart Status button and 
through other contextual functions within the Oracle Enterprise Manager 
application. However, you can view the full set of documentation for all the 
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following types of metrics and events independently through your web browser 
without having to access the Oracle Enterprise Manager application. The 
documentation available through your browser provides a comprehensive Table of 
Contents, an index keyword search, and a full text search function.

■ Oracle Database

■ Windows NT

■ IBM AIX

■ Sun Solaris

■ HP-UX

■ Compaq Tru64

■ SAP R/3 System

■ Oracle Applications system

For each of these types of metrics and events, the following information is 
provided.

For Metrics:

■ Classes

■ Charts

■ Data Items

■ Description

■ Source

■ User Action

■ Event Tests

■ Description

■ Source

■ Parameters

■ Output

■ Frequency

■ User Action
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To access each documentation set, open the appropriate file below in a web 
browser:

■ Oracle Database -- ORACLE_HOME/doc/EM/Webhelp/dba/dba.htm

■ Windows NT -- ORACLE_HOME/doc/EM/Webhelp/nt_os/NT_OS.htm

■ IBM AIX -- ORACLE_HOME/doc/EM/Webhelp/aix/AIX.htm

■ Sun Solaris -- ORACLE_HOME/doc/EM/Webhelp/sol/SOL.htm

■ HP-UX -- ORACLE_HOME/doc/EM/Webhelp/hpux/HPUX.htm

■ Compaq Tru64 -- ORACLE_HOME/doc/EM/Webhelp/dec/DEC.htm

■ SAP R/3 -- ORACLE_HOME/doc/EM/Webhelp/sap/sap.htm

■ Oracle Applications System -- ORACLE_
HOME/doc/EM/Webhelp/oafnd/OAFND.htm
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4
Introduction to Oracle Index Tuning Wizard

The Oracle Index Tuning wizard is a software application that identifies tables with 
inefficient indexes and makes recommendations which will improve access to those 
tables.

The Index Tuning wizard:

■ Identifies tables in need of index changes

■ Presents its findings in reports

■ Implements the recommendations for you

The Index Tuning wizard is intended for use with the Oracle cost-based optimizer. 
The recommendations made by the Index Tuning wizard will optimize index usage 
for the Oracle cost-based optimizer. Therefore, you should not use the Index Tuning 
wizard for those schemas where rule-based optimization is used.

This chapter describes when to use the Index Tuning wizard, how to access the 
Index Tuning wizard, and the Index Tuning wizard interface.

When to Use the Index Tuning Wizard 
You can use the Index Tuning wizard to proactively maintain optimal indexes for 
your database. You should run the Index Tuning wizard regularly to evaluate 
whether index changes should be made to improve SQL query performance. The 
Index Tuning wizard may recommend adding new indexes, changing existing 
indexes, or changing the type of an index.

You should also use the Index Tuning wizard when one of the following situations 
occurs: 

■ A user has reported unacceptable response times for a query
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■ New applications have been added to the database environment

■ Existing application SQL has been modified

■ The database server has been upgraded to a new version

■ Table sizes within the database have increased substantially

Any of these factors may impact the indexing decisions for the database.

Accessing the Index Tuning Wizard
You can access the Index Tuning wizard in the following ways:

■ From the Oracle Enterprise Manager Tuning Pack tool drawer

■ Through the Oracle Expert application

If you have the Oracle Expert application installed, you can launch the Index 
Tuning wizard from the Oracle Expert Tools menu.

The Index Tuning wizard makes two database connections:

1. The Index Tuning wizard connects to its repository to store and analyze data 
required for index tuning. 

2. The Index Tuning wizard uses the database credentials defined in Oracle 
Enterprise Manager console to connect to the target database for index tuning.

Index Tuning Wizard Interface
When you first access the Index Tuning wizard, you are greeted with a Welcome 
screen that provides some of the advantages of using the Index Tuning wizard.

You will be lead through the following screens:

■ Application Type

■ Schema Selection

■ Index Recommendations

■ Analysis Report and Script

Note: In either case, you must first select a database in the 
navigator tree before launching the Index Tuning wizard.
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■ Finish

Each of these screens is described in the following sections.

Application Type
On this screen, you choose the type of application that is primarily being used for 
the target database being tuned: Online Transaction Processing (OLTP), data 
warehousing, or multipurpose.

Schema Selection
On this screen, you have the opportunity to select the schemas you wish to 
evaluate. The Any Schema option tells the Index Tuning Wizard to select any 
schema which has a table referenced by one of the worst performing SQL 
statements. Select this option if you want an overview of the database’s overall 
performance problems.

The purpose of the Selected Schemas option is to hide recommendations for 
schemas that you are not responsible for tuning or you do not wish to tune at the 
current time. Select this option if you only want recommendations for schemas you 
control. The schemas you select may or may not be the worst performers so you 
may or may not get tuning recommendations for all of the selected schemas.  

When you first use the Index Tuning wizard, it is best to let the wizard select any 
schema so you will see an overall view of the problem areas. You can then focus on 
specific areas of the database for which you have control.

Index Recommendations
From this screen you can:

■ Have the Index Tuning wizard generate the index recommendations, that is, 
collect and analyze the data to provide the index recommendations.

■ Choose the index recommendations to be implemented.

The Index Tuning wizard provides a work-in-progress dialog box.

You can stop the generation at any time. The Index Tuning wizard deletes all the 
created files in preparation for the next generation.

Once the recommendations are generated, use this screen to choose the index 
recommendations you want to implement. The Details button provides additional 
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information about each recommendation. To activate the Details button, select a 
recommendation.

Analysis Report and Script
The Analysis Report and Script page displays  the Analysis Report and Script tabs 
to view all of the recommendations for a tuning session, as well as the rationale for 
those recommendations. 

During an analysis, the Index Tuning Wizard sifts through the collected data, uses 
its rules to generate tuning recommendations, then stores the information for the 
Analysis report in the repository. The Analysis report information stays in the 
repository until another analysis is performed for the tuning session.

The Script tab displays the SQL script needed to implement the recommendations 
that you selected on the Index Recommendations page. You can view the SQL before 
choosing to implement the recommended changes. 

You can print and save the report and script from this page.

Finish
This screen allows you to implement and save the index tuning recommendations. 
The possibilities are:

■ Implement the selected recommendations immediately

■ Save the recommendations as an implementation script (Provides you with 
another opportunity to save the analysis report and script if you have not 
already done so.)

■ Save the recommendations to an Oracle Expert Tuning Session (Standard 
Management Pack users must have the Oracle Tuning Pack installed for this 
option to work.)

When you click Finish, the recommendations will be saved and/or implemented 
according to the choices made.

Note: The Analysis report for a tuning session is available only 
after the Index Tuning Wizard has analyzed the collected data.
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5
Overview of the Change Management

Applications

The change management applications provided by the Oracle Standard 
Management Pack are a group of integrated applications used to track changes to 
database object definitions.  The change management applications are components 
of Oracle Enterprise Manager.

The change management applications provided by the Oracle Standard 
Management Pack are:

■ Create Baseline

■ Compare Database Objects

■ Change Manager

This chapter provides an overview of change management applications, concepts, 
and features.

The following section describes new features for this release of the change 
management applications.

New Features for the Change Management Applications
The following list describes the major new features for this version of the change 
management applications:

■ Instance parameters can be included in baselines

The Create Baseline and Compare Database Objects applications support Oracle 
instance parameters in this release.
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You can use Create Baseline to create a baseline that includes definitions and 
instance parameter settings for a database, or you can create a baseline that 
contains only the instance parameters for a database.

You can use Compare Database Objects to compare a database’s current 
instance parameter settings to the database’s instance parameter settings that 
were captured in a previous baseline. Or, you can compare two different 
baselines taken at different points in time that include a database’s instance 
parameter settings.

Comparing instance parameters differences for a database can help you monitor 
changes in the database’s configuration, which may enable you to diagnose 
performance problems.

■ Change management applications can be run standalone (without a connection 
to the Oracle Management Server)

In previous releases, change management applications could only be run after 
connecting to an Oracle Management Server. With this release, you can run 
change management applications standalone (without a connection to the 
Oracle Management Server). See "Running Change Manager Connected to an 
Oracle Management Server or Standalone" on page 6-1 for more information.

To run Change Management Pack applications standalone, you must have a 
standalone repository. See the Oracle Enterprise Manager Configuration Guide for 
information on the steps to perform before creating a standalone repository.

■ Change management applications run in a web browser

In this release, you can run change management applications from a web 
browser. To do this, you start the Oracle Enterprise Manager Console in a 
browser, then choose Tools->Change Management Pack->Change Manager to 
start Change Manager in the browser. Other change management applications 
that you start from Change Manager also run in the browser.

The majority of the change management application features are available from 
a browser. However, you cannot perform import and export operations from 
the Change Manager application when it is running in a browser.

For information on running the Oracle Enterprise Manager Console in a web 
browser, see the Oracle Enterprise Manager Configuration Guide.
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Database Objects Supported by the Change Management Applications
The types of database object definitions that the change management applications 
supports are:

■ Cluster

■ Database link

■ Function

■ Index

■ Materialized view

■ Materialized view log

■ Package

■ Package body

■ Procedure

■ Profile

■ Refresh group

■ Role

■ Rollback segment

■ Sequence

■ Synonym

■ Table

■ Tablespace

■ Trigger and instead-of trigger

■ User

■ View

The change management applications currently do not support the following 
features of the database objects in the previous list:

■ Object-oriented features:

– Tables and snapshot logs that refer to user-defined data types.

– Object tables
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– Nested tables

– Object views

■ Snapshots that are not read-only

For a more complete list that describes the level of support the change management 
applications offer for specific database objects and attributes, see the section on 
currently unsupported database features and attributes in the Change Management 
Pack section of the Oracle Enterprise Manager Readme.

Understanding Change Management Objects
The following types of objects are created only by change management applications 
and are used to track changes to other object definitions:

■ Baselines

A baseline is a group of database object definitions captured by the Create 
Baseline application at a particular point in time. Each baseline has the name of 
its baseline specification and a version number. A baseline is stored in a format 
that can be used by multiple change management applications.

A baseline specification is used to generate baselines. A baseline specification 
includes a baseline name, source database, scope specification, and owner. The 
baseline name can be changed after the baseline specification is created, but the 
source database, scope specification, and owner cannot. The scope specification 
for a baseline is a set of criteria that an object must meet to be included in the 
baseline generated from the baseline specification. The scope specification 
describes the types of database object definitions to be included in the baseline, 
the schemas in which to look for those object definitions, and the names of 
those object definitions. See "Overview of Create Baseline" on page 5-6 for more 
information about baselines.

■ Comparisons

A comparison identifies the differences found by the in two sets of database 
object definitions that you have specified in the Compare Database Objects 
application. Each comparison has the name of its comparison specification and 
a version number. Comparison results are displayed in the Comparison Viewer.

A comparison specification is used to generate comparisons. A comparison 
specification is defined by its name, source database, scope specification, and 
owner. The name can be changed after the comparison specification is created, 
but the source database, scope specification, and owner cannot. The scope 
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specification for a comparison is a set of criteria that the set of  objects to be 
compared must meet to be included in a comparison generated from the 
comparison specification. The scope specification describes the types of 
database object definitions to be included in the comparison, the schemas in 
which to look for those object definitions, and the names of those object 
definitions. See "Overview of Compare Database Objects" on page 5-8 for more 
information about comparisons.

Change Management Applications
The Change Manager application is the central interface for the change 
management applications. Change Manager provides direct or indirect access to all 
change management features. For example, Change Manager provides direct access 
to the change management history features. It provides indirect access to the other 
change management applications, which can be started from Change Manager. See 
"Starting Change Manager" on page 6-3 for more information on starting Change 
Manager and "Starting Change Management Applications from Change Manager" 
on page 6-5 for more information on starting other applications from Change 
Manager.

With change management applications, you can track changes by:

■ Capturing the current definitions of a set of database objects in a baseline.

■ Creating new versions of a baseline at regular intervals to track changes in that 
set of database objects over time.

■ Comparing a set of object definitions in one schema, database, or baseline to 
another set of definitions (in a schema, database, or baseline). A comparison 
identifies differences between two sets of definitions.

■ Creating new versions of a comparison at regular intervals to determine the 
differences between the two sets of definitions over time.

The applications and their functions are:

– Create Baseline

Captures one or more definitions from one database.

– Compare Database Objects

Compares a set of object definitions in one schema, database, or baseline to 
another set of definitions (in a schema, database, or baseline).
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The following sections provide additional overview information on the change 
management applications.

Overview of Change Manager
The Change Manager application is the central interface for the change 
management applications. Change Manager gives you direct or indirect access to 
change management operations.

Using Change Manager, you can view change management objects (baselines and 
comparisons), as well as check on the status of current tasks. You can also view 
history information that tells you which change management operations were 
performed by what users at what time.

You can also use Change Manager to start the other change management 
applications.

Figure 5–1 shows the functional capabilities of Change Manager.

Figure 5–1 Functional Capabilities of Change Manager

See Chapter 6, "Using Change Manager" on page 6-1 for more information on using 
Change Manager. The chapter includes information on starting Change Manager, 
starting other applications from Change Manager, and on the features that are 
accessible from the Change Manager application.

Overview of Create Baseline
The Create Baseline application guides you step-by-step through the process of 
capturing a database (or a subset of a database) in a form that is readable by other 
change management applications.  Create Baseline lets you specify the set of 
database object definitions to capture, captures those definitions in their current 
state at the time of the capture operation, and displays the baseline in the Baseline 
Viewer.

direct or indirect access to all
change management features

NU-3705A-AI

Provides ...
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Create Baseline can capture object definitions in both of the following forms:

■ A baseline.  The baseline stores definitions in a form that other change 
management applications can use. A baseline is created during every capture 
operation.

■ A SQL DDL script.  The script contains the SQL statements that correspond to 
the captured definitions. You can use the script to save a textual version of the 
definitions or as input to CASE tools that accept SQL DDL input. You can also 
use individual SQL statements from the script to create definitions in a new 
database. You have the option of whether or not to create a SQL DDL script. To 
save time during a capture operation, you can defer the creation of the SQL 
DDL script.

 Figure 5–2 shows the functional capabilities of Create Baseline.

Figure 5–2 Functional Capabilities of Create Baseline

You can start Create Baseline from Change Manager. See "Starting Change 
Management Applications from Change Manager" on page 6-5 for information on 
starting Create Baseline from Change Manager.

The Baseline Viewer displays baselines created with Create Baseline. You can also 
use Baseline Viewer to generate a SQL DDL script for the baseline if you did not 
generate one when the baseline was captured. See "Starting Change Management 
Applications from Change Manager" on page 6-5 for information on starting 
Baseline Viewer from Change Manager.

To generate a report that includes information about the objects in a baseline, view 
the baseline in Baseline Viewer, click the Database Objects folder, and choose 
File->List Report. The online help contains more information about the specifics of 
using Baseline Viewer.

from one databaseone or more
definitions ...
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Capturing a Baseline from the Oracle Enterprise Manager Console
When you have Oracle Standard Management Pack installed, you can also perform 
a capture operation from the Oracle Enterprise Manager Console by following these 
steps:

1. Select a database, type, or schema folder in the Oracle Enterprise Manager 
navigator.

2. Click the right mouse button.

3. On the context menu, choose Standard Management->Capture Database 
Objects. 

Create Baseline is started to capture a baseline for the selected database, then after 
the capture operation is completed, the Baseline Viewer is started to allow you to 
view the baseline.

The online help contains more information about the specifics of using Create 
Baseline.

Overview of Compare Database Objects
The Compare Database Objects application guides you step-by-step through the 
process of selecting two sets of object definitions for a comparison. The object 
definitions can be selected from current database definitions or they can be selected 
from baselines created earlier with Create Baseline. Differences that are found 
between the two sets of object definitions are displayed in the Comparison Viewer.

The result of comparing two sets of object definitions using Compare Database 
Objects is called a comparison. You can view a comparison, name it, and save it 
using the Comparison Viewer.

Figure 5–3 shows the functional capabilities of Compare Database Objects.

Figure 5–3 Functional Capabilities of Compare Database Objects

two sets of definitions ...
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from different schemas within
a database or baseline, or from
two databases, two baselines,
or a database and a baseline
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You can start Compare Database Objects from Change Manager. See "Starting 
Change Management Applications from Change Manager" on page 6-5 for 
information on starting Change Database Objects from Change Manager.

You can also generate a report about the results of a comparison by choosing 
File->Report in Comparison Viewer.  The report includes:

■ A description of what you compared.

■ The comparison options you selected.

■ A summary of the comparison results.

■ The comparison tree and comparison details (optional).

Performing a Comparison from the Oracle Enterprise Manager Console
When you have the Oracle Standard Management Pack installed, you can also 
perform a comparison operation from the Oracle Enterprise Manager Console by 
following these steps:

1. Select a database, type, or schema folder in the Oracle Enterprise Manager 
navigator.

2. Click the right mouse button.

3. On the context menu, choose Standard Management->Compare Database 
Objects. 

Compare Database Objects is used to specify the two sets of database object 
definitions to include in a comparison, and the Comparison Viewer is used to 
display the results of the comparison.

The online help contains more information about the specifics of using Compare 
Database Objects and Comparison Viewer.

Sample Uses for the Change Management Applications
This section provides some sample uses for change management applications in an 
application development environment.

Create Baseline Specifications
At the beginning of a new development cycle, use Create Baseline to create one or 
more baseline specifications that identify the database and schema object definitions 
used in your application.
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Create Baseline Versions at Key Points
You can use a baseline specification to create a baseline that captures the database 
and schema object definitions used in your application at the start of the 
development cycle. Then, at regular intervals (such as daily or weekly) and at 
development milestones (such as beta freeze), create a new version of the baseline 
that captures the definitions at that point in time. These baseline versions provide a 
record of the definitions throughout the development cycle.

Generate Reports for Definitions in Baselines
Baseline Viewer allows you to view baselines and to generate a report that describes 
the definitions captured in the baseline.

Generate SQL Statements for Baseline Definitions
You can also use Baseline Viewer to generate the SQL data definition statements for 
each of the definitions in the baseline, and save these SQL statements to a file. The 
statements could then be used in a script to reproduce the definitions at some point 
in the future.

Create Comparison Specifications
Use Compare Database Objects to create comparison specifications that identify two 
sets of database definitions that you want to compare. The two sets of database 
definitions to be compared can be from two baselines, two databases, or a database 
and a baseline. Among the differences that comparisons can identify are text 
differences in objects such as procedures, packages, or views, and differences in 
instance parameters.

Create Comparison Versions to Track Definition Changes Over Time
You can use comparison specifications to create multiple versions of a comparison. 
You can use comparison versions to track changes to two sets of definitions over 
time.

For example, you can use a comparison specification to create a comparison that 
identifies the differences between the definitions in the original baseline for your 
application and those same definitions in your current database. Each time you 
create a new version of this comparison using the comparison specification, that 
comparison version identifies the differences between the original definitions at the 
start of the development cycle and those same definitions at the current time.

You could also use another comparison specification to create a comparison that 
compares definitions from your most recent (latest) baseline with those same 
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definitions in the previous (2nd latest) baseline. Each time you create a new version 
of this comparison using the comparison specification, that comparison version 
identifies the differences in the definitions since the previous baseline.

Generate Reports for Differences Identified in Comparisons
When viewing a comparison in the Comparison Viewer, you can choose File->List 
to generate a report that describes the differences between the two sets of 
definitions included in the comparison.

Use History Features to Track Definition Changes
You can use Change Manager’s history features to see when baselines were 
captured and comparisons were performed. Change Manager’s history features 
also record which administrator performed these tasks and the status of each task 
(for example, whether a capture operation succeeded or failed). You can print a 
report that includes this history information. See "Viewing History Entries for 
Tasks" on page 6-8 for more information on using Change Manager’s history 
features.

The  change applications and Plan Editor use many of the same components to 
create change plans, scripts, impact reports, and execution logs. Therefore, after you 
have used a components in one of the applications, you will know how to use it in 
another.

Using Help
Online help is provided for all of the Oracle Change Management Pack 
applications. Note that the Oracle Standard Management Pack includes only the 
Change Manager, Baseline Viewer, DB Capture, and DB Diff applications, and 
provides read-only access to database object definitions. Also, you cannot create 
change plans with Oracle Standard Management Pack. You can display the 
Contents page of the Oracle Change Management Pack help system, or you can 
display a help topic for your current context in an application.

Displaying the Contents Page for Help
Depending on the application that you are using, you can display the Contents page 
for the Oracle Change Management Pack online help by using one of the following 
methods:

■ Press F1. If the Contents page for the help system does not display, click the 
Navigator button on the Help Topic Window toolbar.



Using Help

5-12 Getting Started with the Oracle Standard Management Pack

■ Click the ? on the application toolbar. This applies to Change Manager, Baseline 
Viewer, and Comparison Viewer only.

■ Choose Help->Contents. This applies to Change Manager, Baseline Viewer, 
and Comparison Viewer only.

Use the help system’s Contents page or Help Search page to locate help topics of 
interest. To access the Help Search page, choose Tools->Search on the Help 
Navigator window.

Displaying a Help Topic for Your Current Context in an Application
You can display context-sensitive help in several ways, depending on your context 
in an application.

■ If a Help button exists, click it.

■ If a Help button does not exist, click the object that you are interested in, then 
press F1.

■ Some wizard pages for the change management applications also display 
property pages. To access help for the wizard page, click the Help button at the 
bottom left corner of the page. To access help for a property page, click a field in 
the property page, then click the Help button beneath the property page. If a 
Help button does not exist beneath the property page, click a field in the 
property page, then press F1.

Finding a Particular Type of Help Topic
In addition to providing context-sensitive help, the Oracle Change Management 
Pack help system contains conceptual topics, task topics, and a glossary. To locate 
each type of topic:

■ Help topics whose titles begin with words such as "About," "Introduction," or 
"Overview" are conceptual topics. These topics usually provide overview 
information about change management applications or conceptual information 
that you should be aware of before performing a particular task. They do not 
provide step-by-step instructions for accomplishing a task. The Conceptual 
Topics book on the help system’s Contents page includes all of the conceptual 
topics in the Oracle Change Management Pack help system.

■ Help topics whose title begin with the word "To" are task topics. These topics 
provide step-by-step instructions for accomplishing a task. They do not provide 
conceptual information that you should be aware of before performing the task. 
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The Task Topics book on the help system’s Contents page includes all of the 
task topics in the Oracle Change Management Pack help system.

■ The Oracle Change Management Pack glossary is available by accessing the 
Glossary book on the help system’s Contents page.
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6
Using Change Manager

The Change Manager application is the change management central interface.  
Change Manager gives you direct or indirect access to all of the change 
management operations (in cases where Change Manager cannot directly perform 
an operation, such as capturing or comparing object definitions, Change Manager 
starts the application that performs that operation).

Running Change Manager Connected to an Oracle Management Server 
or Standalone

You can run Change Manager connected to an Oracle Management Server or not 
connected to an Oracle Management Server. When you run Change Manager 
without connecting to an Oracle Management Server, you are running Change 
Manager standalone.

When you run Change Manager connected to an Oracle Management Server:

■ Change Manager provides access to all the change management objects owned 
by all users in the Oracle Management Server repository. Objects are ordered by 
owner in the Change Manager navigator tree.

■ Each user has read and write access to the objects that he or she owns, and has 
read-only access to objects owned by other users.

■ Other change management applications started from Change Manager also run 
connected to the Oracle Management Server.

■ You can submit change plan scripts as jobs using the Oracle Enterprise Manager 
job system.

When you run Change Manager standalone:
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■ Change Manager provides access to the change management objects in your 
standalone repository. Because the standalone repository contains only objects 
that you created, the Change Manager navigator tree displays only your change 
management objects.

■ You have full access to your objects, but no access to any other objects.

■ Other change management applications started from Change Manager also run 
standalone.

■ You cannot submit change plan scripts as jobs using the Oracle Enterprise 
Manager job system, but you can execute scripts interactively.

Creating a Standalone Repository for Change Management Applications
A standalone repository is required to store Change Management Packchange 
management objects created during a standalone change management session. 
Read and follow the steps to perform before creating a standalone repository in the 
Oracle Enterprise Manager Configuration Guide.

The next time you start Change Manager standalone, a repository login dialog box 
prompts you for the Username, Password, and Service credentials of the user that 
owns the schema to be used for your standalone repository. When you provide the 
credentials for that user, the standalone repository tables needed by the change 
management applications will be created for you in that user’s schema.

Changing Your Standalone Change Management Repository
At some point after creating a standalone repository for change management 
objects created during your change management sessions, you might decide that 
you want to use a different standalone repository.

To start using a different standalone repository, you must:

1. Make sure that you have followed the steps in the Oracle Enterprise Manager 
Configuration Guide that are a prerequisite for creating the new standalone 
repository.

2. In the ORACLE_HOME/sysman/config/ClientConfig.properties file (where 
ORACLE_HOME is the directory in which Oracle Enterprise Manager is 
installed), delete the lines that contain the following parameters:

■ OEM.REPOSITORY.USER

■ OEM.REPOSITORY.PASSWORD
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■ OEM.REPOSITORY.DATABASE

Removing these lines from ClientConfig.properties removes information about 
the current standalone repository that is being used for standalone change 
management objects.

3. The next time you start Change Manager standalone, you are prompted for 
repository credentials for your standalone repository. Specify the Username, 
Password, and Service credentials of the user that owns the schema to be used 
for your standalone repository. The Username, Password, and Service 
information that you specify for the new standalone repository is stored in the 
ClientConfig.properties file.

Change Manager uses the information in the ClientConfig.properties file to 
determine the standalone repository in which to store information from your 
change management session.

Starting Change Manager
You can start the Change Manager application in any of the following ways:

■ From the Oracle Enterprise Manager Console, use any of these methods:

– Select a database in the navigator panel, click the right mouse button, point 
to the Related Tools menu option, then click Change Manager.

– On the Tools menu, point to Standard Management Pack, then click 
Change Manager.

– Click the Standard Management Pack drawer, then click the Change 
Manager icon.

When Change Manager is started from the Console using any of these methods, 
the mode in which the Console is running (connected to the Oracle 
Management Server or standalone) determines the mode in which Change 
Manager will run.

■ On UNIX or in a DOS window on an NT machine, set default to the ORACLE_
HOME/bin directory (where ORACLE_HOME is the directory in which Oracle 
Enterprise Manager is installed), then enter the following in lowercase 
characters at the command line prompt:

oemapp ocm
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When you start Change Manager using this method, you are prompted whether 
you want to run Change Manager connected to the Oracle Management Server 
or standalone.

■ On the Windows Start menu, point to Programs, then to the Oracle Home 
where Oracle Enterprise Manager is installed, then to Standard Management 
Pack, then click Change Manager.

When you start Change Manager using this method, you are prompted whether 
you want to run Change Manager connected to the Oracle Management Server 
or standalone.

See "Starting Change Management Applications from Change Manager" on 
page 6-5 for more information on starting the other change management 
applications from Change Manager.

Using the Change Manager Main Window
The Change Manager main window has a navigator tree on the left and a detail 
view on the right.

When Change Manager is running connected to an Oracle Management Server, the 
navigator tree displays the following change management objects, organized by 
owner:

■ baselines

■ comparisons

The tree contains the Baselines and Comparisons folders, even if objects of these 
types have not been created yet.

If Change Manager is running standalone, the tree displays only the change 
management objects belonging to the owner of the standalone repository being 
used.

If the Change Manager navigator tree contains no objects, this means that no 
baselines or comparisons have been created in the repository. When you create 
these objects, they appear in the Change Manager tree.

When you select a change management object or object folder and click the right 
mouse button, a context menu is displayed that lists the operations that can be 
performed in the current context. If you select an object that you do not own, some 
of the operations on the context menu are unavailable (for example, you cannot 
remove or modify an object that you do not own, because you have read-only access 
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to objects owned by other users). On the context menu, choose any available 
operation that you are interested in performing.

When the Change Manager Users folder (the root of the Change Manager tree) is 
selected, the detail view to the right of the Change Manager tree provides 
information about change management applications and the operations that they 
can perform. Click on an application’s icon in the detail view to learn more about 
the operations that the application can perform.

When other folders or objects are selected in the Change Manager tree, the detail 
view provides related information about the selected folder or object.

Starting Change Management Applications from Change Manager
You start the other change management applications and viewers from Change 
Manager, as follows:

■ Create Baseline

Choose Object->Create Baseline.

■ Compare Database Objects

Choose Object->Compare Database Objects.

■ Baseline Viewer

Expand the Change Manager folder, user folder, and Baselines folder in the 
Change Manager tree, select a baseline, then choose Object->View Baseline.

■ Comparison Viewer

Expand the Change Manager folder, user folder, and Comparisons folder in the 
Change Manager tree, select a comparison, then choose Object->View 
Comparison.

You can also start a change management application by clicking the Change 
Manager toolbar icon for that application.

Note: Change Manager provides right mouse button support for 
some operations.

After you select an object in the Change Manager navigator, click 
the right mouse button to display a menu of options. Any menu 
options that are not appropriate for the given object are unavailable 
from the menu.
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When you start a change management application from Change Manager, the mode 
in which Change Manager is running (connected to the Oracle Management Server 
or standalone) determines the mode in which the other change management 
application will run.

Working with Baselines
Table 6–1 describes how to use Change Manager to perform different types of 
baseline operations.

For more information on working with baselines, see:

■ "Viewing History Entries for Tasks" on page 6-8 for more information on 
viewing history entries for baseline tasks.

Table 6–1 Performing Baseline Operations 

Operation Steps for Performing the Operation

Create a new baseline Choose Object->Create Baseline and follow the steps in the 
Create Baseline application.

View a baseline Select the baseline in the tree, then choose Object->View 
Baseline.

Delete a baseline Select the baseline in the tree, then choose Object->Remove. 
This deletes all the versions of the baseline.

Export a baseline to a file Choose Tools->Export Plans/Baselines/Comparisons, then 
specify the baseline to export and the name of the export file.

Import a baseline from a 
file

Choose Tools->Import Plans/Baselines/Comparisons, then 
specify the name of the export file and the baseline to import.

Create a new version of a 
baseline

Select the baseline in the tree, then choose Object->Recapture.

View a previous version of 
a baseline

Select the baseline in the tree, then choose Object->Show 
Versions. In the Versions dialog box, click the version you 
want to view, then click View.

Delete a previous version 
of a baseline

Select the baseline in the tree, then choose Object->Show 
Versions. In the Versions dialog box, click the version you 
want to delete, then click Remove.

View history entries for 
baseline tasks

Choose View->Show History. In the History dialog box, view 
history entries for completed baseline tasks on the History 
page.
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■ "Working With a Particular Version of a Baseline or Comparison" on page 6-9 
for more information on working with particular versions of baselines.

■ "Exporting and Importing Baselines and Comparisons" on page 6-9 for more 
information on exporting and importing baselines.

Working with Comparisons
Table 6–2 describes how to use Change Manager to perform different types of 
comparison operations.

For more information on working with comparisons, see:

Table 6–2 Performing Comparison Operations 

Operation Steps for Performing the Operation

Create a new comparison Choose Object->Compare Database Objects and follow the 
steps in the Compare Database Objects application.

View a comparison Select the comparison in the tree, then choose Object->View 
Comparison.

Delete a comparison Select the comparison in the tree, then choose 
Object->Remove. This deletes all the versions of the 
comparison.

Export a comparison to a 
file

Choose Tools->Export Plans/Baselines/Comparisons, then 
specify the comparison to export and the name of the export 
file.

Import a comparison from 
a file

Choose Tools->Import Plans/Baselines/Comparisons, then 
specify the name of the export file and the comparison to 
import.

Create a new version of a 
comparison

Select the comparison in the tree, then choose Object->Repeat 
Comparison.

View a previous version of 
a comparison

Select the comparison in the tree, then choose Object->Show 
Versions. In the Versions dialog box, click the version you 
want to view, then click View.

Delete a previous version 
of a comparison

Select the comparison in the tree, then choose Object->Show 
Versions. In the Versions dialog box, click the version you 
want to delete, then click Remove.

View history entries for 
comparison tasks

Choose View->Show History. In the History dialog box, view 
history entries for completed comparison tasks on the History 
page.
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■ "Viewing History Entries for Tasks" on page 6-8 for more information on 
viewing history entries for comparison tasks.

■ "Working With a Particular Version of a Baseline or Comparison" on page 6-9 
for more information on working with particular versions of comparisons.

■ "Exporting and Importing Baselines and Comparisons" on page 6-9 for more 
information on exporting and importing comparisons.

Viewing History Entries for Tasks
You can view history entries that show the status of the following change 
management tasks:

■ Capturing baselines

■ Performing comparisons

By viewing the history entries for completed tasks, you can determine when each 
change management task was performed and its completion status.

To view the history entries for tasks in the current change management repository, 
on the Change Manager View menu, choose the Show History option, which 
displays the History dialog box. The History dialog box allows you to view 
completed tasks.

Viewing Completed Tasks
Click the History tab of the History dialog box to view completed tasks.

The history entries on the History page of the History dialog box enable you to 
track the change management tasks that have been completed. Each row on the 
History page is a history entry for one completed task. The status for a particular 
history entry tells you whether the task completed successfully or not.

On the History page, you can perform the operations shown in Table 6–3:

Table 6–3 Operations That Can be Performed on Completed Tasks 

Operation Steps to Perform the Operation

Remove a task Select a task and click Remove.

Update the History page 
display

Click the Refresh button. Any new completed tasks are 
displayed.
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Working With a Particular Version of a Baseline or Comparison
After you create a baseline specification, you can use the specification to generate 
multiple baselines over time. Similarly, after you create a comparison specification, 
you can use it to generate multiple comparisons over time.

By default, when you select a baseline or comparison in Change Manager, any 
operations you perform are carried out on the latest version of that object. In some 
cases, however, you may want to view or remove an earlier version of the object. To 
do so, after you select the object in Change Manager, on the Object menu, click 
Show Versions. This displays the Versions dialog box. In the Versions dialog box, 
select the version of the object that you are interested in, then click View to view the 
selected version of the object in the appropriate change management window or 
click Remove to remove the selected version of the object from the Oracle 
Enterprise Manager repository.

Exporting and Importing Baselines and Comparisons
You can export and import baselines and comparisons using Change Manager. 
After you export one or more of these objects to a file, you can then import the 

View a task Select a task and click GoTo. The appropriate change 
management application window is opened in the correct 
context for viewing the task.

Save history entries to a 
file

Click the Save List button. The Save List dialog box lets you 
save some or all of the task history entries in a file. You have 
the option of viewing and printing the information to be 
included in the file before saving the file.

Sort history entries Click a column heading on the History page. The first time you 
click a heading, the history entries are sorted in ascending 
order, using the values in that column. If you click again on the 
same heading, the history entries are sorted in descending 
order, using the values in that column.

Note: When you remove a version of a baseline or comparison, 
the version numbers for the remaining versions of that object 
remain the same.

Table 6–3 Operations That Can be Performed on Completed Tasks (Cont.)

Operation Steps to Perform the Operation
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objects into another repository, which copies the objects from one repository to 
another.

To export baselines or comparisons:

1. In Change Manager, choose Tools->Export Plans/Baselines/Comparisons.

2. In the Export Plans/Baselines/Comparisons dialog box, select the object or 
objects to export, then click Export.

3. In the Export Plans/Baselines/Comparisons to which file? dialog box, select a 
file into which the selected objects will be exported, then click Save.

To import baselines or comparisons:

1. In Change Manager, choose Tools->Import Plans/Baselines/Comparisons.

2. In the Import Plans/Baselines/Comparisons from which file? dialog box, 
identify the file that contains the object or objects that you want to import, then 
click Open.

3. In the Import Plans/Baselines/Comparisons dialog box, select the object or 
objects that you want to import, then click Import. If the import utility 
discovers that any of the objects being imported has the same name as an 
existing object in the current repository, you will be prompted to either rename 
the object being imported or to cancel the import operation for that object.
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7
Using Oracle TopSessions

This chapter discusses the following Oracle TopSessions topics:

■ Overview of Oracle TopSessions

■ Before You Use the Oracle TopSessions Chart

■ Displaying the TopSessions Chart

■ Overview of Session Activity

■ Viewing Details About a Given Session

■ Customizing the Session Information You Display

Overview of Oracle TopSessions
You can use Performance Manager to assist you in identifying performance 
bottlenecks within your system and database environment. The TopSessions chart 
displays database sessions that are contributing most heavily to database activity. 
You can display various details for these sessions, including the SQL statements, 
and resource usage.

You can obtain an overview of session activity by displaying the top sessions sorted 
by a statistic of your choosing. For any given session you can then drill down for 
more detail, or if you choose, you can terminate the session using the Kill Session 
option.

The TopSessions chart provides a methodology for identifying and correcting 
certain database performance problems. For example, when sudden file I/O load is 
detected, you can first identify the sessions contributing most to the problem and 
then isolate the executing SQL statements in user applications for those sessions. 
You can then analyze the SQL explain plans for those SQL statements to determine 
how best to resolve the problem.
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Once populated with data, the TopSessions chart includes a multi-column list of 
summary information for each session connected to the database instance or for 
each of the top n sessions as measured by the selected sort statistic.

You can also access the TopSessions chart from the Enterprise Manager console by 
selecting TopSessions from the Diagnostics Pack tool drawer. You can access 
information about individual sessions via drill downs from this chart.

The TopSessions chart displays the sessions sorted by the statistic specified on the 
Options tab of the TopSessions property sheet. By using the Set Options button in 
the toolbar the chart can be customized to show only the items of interest and the 
sort criteria can be changed. You can specify the number of sessions to display on 
the Options tab as well. See "Customizing the Session Information You Display"  on 
page 7-15 for more information about customizing the TopSessions display.

You can re-sort the sessions by clicking on the statistic column you want to use as 
the sort criterion. Clicking on the column header toggles the sort order in 
descending or ascending order. This changes only the display sort order and has no 
effect on the top "n" sorting/reduction done by selecting the sort item in the 
Options page.

The File, View, Collection, Tools and Help menus are the same as those in the chart 
window for Performance Manager. The Drilldown menu is customized to reflect 
some of the tasks specific to TopSessions.

Before You Use the Oracle TopSessions Chart
Before you can use the TopSessions chart on pre-Oracle 9i databases, you must first 
run a SQL script that defines the OEM_MONITOR role which contains all the 
privileges required to use the Diagnostics Pack products.  Granting the 
OEM_MONITOR role is the best way to ensure that a user has the correct privileges 
to use the TopSessions functions. The OEM_MONITOR role has been granted more 
privileges in the 9i version that help to provide better functionality and 
performance.

For 9i databases, the SQL script, catsnmp.sql, is run by default as part of the 9i 
database creation process. For all versions of the database prior to 9i, you must 
manually run a SQL script to define the OEM_MONITOR role and create the 
necessary views.

For versions 8.1.5, 8.1.6, and 8.1.7 of the database, you must run the script 
catsnmp_8i.sql. For versions 8.0.5 and 8.0.6 of the database, you must run the script 
catsnmp_80.sql. For version 7.3.4 of the database, you must run script 
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catsnmp_734.sql. The selected script must be executed by a user with SYS 
privileges.

The sql files are located in the Oracle home of the Oracle Enterprise Manager 
installation, $ORACLE_HOME/SYSMAN/ADMIN. You must run the appropriate 
version of the SQL script manually on all pre-9i databases.

The OEM_MONITOR role must be granted to any user wishing to use the Oracle 
Diagnostics Pack. Performance Manager does not require any of these new views in 
order to run, but if you attach to a database that does not have the views, or your 
process does not have the required privileges, or the OEM_MONITOR role  does 
not exist, then an informational message displays.

Displaying the TopSessions Chart
You can display the TopSessions chart from the Oracle Enterprise Manager console, 
from the Start menu, or from within Performance Manager. 

Displaying the TopSessions Chart from the Console
You can display the TopSessions chart from the Oracle Enterprise Manager console 
in any of the following ways:

■ On the Oracle Enterprise Manager console, point to the Standard Management 
Pack drawer, then click TopSessions.

■ On the Tools menu of the Oracle Enterprise Manager console, point to Standard 
Management Pack, then click TopSessions.

■ Click the right mouse button on the target node for which you want to display 
the TopSessions chart and then choose TopSessions from the Related Tools 
menu item on the context menu.

Starting TopSessions from the Start Menu
On the Start menu, follow the path: Start=>Programs=>
ORACLE - $Oracle _Home=>Standard Management Pack=>TopSessions.

Note: ORACLE_HOME represents the home directory in which 
the Standard Management Pack is installed.
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When you launch TopSessions from the Start menu, a database logon dialog box 
appears. By default, you are connected to the database via Direct Connect, allowing 
the application to run in Standalone mode. You can change the connection details 
from the logon dialog to connect to an OMS if you choose. 

Displaying TopSessions in Performance Manager
You can display the TopSessions chart from within Performance Manager by 
following these steps:

1. Point to the database for which you want to display TopSessions in the  
Performance Manager navigator and then choose TopSessions from the list of 
available charts.

The Data Tab appears in the right-side pane.

2. Choose the data sources from the list that appears in the top panel of the Data 
Tab.

3. Select the collection types you want to display from the list at the bottom panel 
of the Data Tab.

4. To filter the sessions you want to display, click on the Session Filtering Tab. 
Filtering allows you to reduce the number of sessions returned by specifying 
criteria that a session must meet in order to be considered part of the sample 
set. For more information about the Session Filtering function, see "Session 
Filtering Options Page" on page 7-17.

5. To limit the number of data sources and to set the sort order for the chart, click 
on the Options Tab.

6. To display the TopSessions chart, click on the Show Chart button at the bottom 
of the panel.

7. To record the chart activity, click on the Record Chart button at the bottom of 
the panel to bring up the Recording Parameters dialog box.

By default, the top n sessions in the main display are sorted by the session logical 
reads statistic. If you want to change the sort statistic and/or the statistic filter, 
choose Options on the Session menu. This displays the Options property sheet, on 
which you can customize the session information displayed in the main display. See 
"Customizing the Session Information You Display" on page 7-15 for more 
information about using the Options property sheet.

Figure 7–1  shows the Oracle TopSessions chart.
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Figure 7–1 Oracle TopSessions Chart

As Figure 7–1  shows, the Oracle TopSessions chart includes the following 
components:

■ Menu bar

■ Toolbar

The following sections describe each of these components.

Oracle TopSessions Menu Bar
The menu bar of the Oracle TopSessions chart includes the following pull-down 
menus:

■ File

■ View

■ Collection

■ Drilldown

■ Help
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File Menu
The File menu on the Charts display window has the following options:

■ Print Screen

Prints the displayed TopSessions chart.

■ Report Chart

Generates a report for the TopSessions chart. When you click the Report Chart 
button, Performance Manager creates a TopSessions chart report in HTML 
format and saves it for you. You can also preview the report by displaying it in 
your Web browser.

■ Close

Closes the displayed TopSessions chart.

View Menu
The View menu on the Charts display window has the following options:

■ Table

Changes the current display to a table chart. Table charts present text 
information, or a large number of instances, in a format that is easy to review.

■ Horizontal Orientation

Changes the chart orientation to horizontal.

■ Vertical Orientation

Changes the chart orientation to vertical.

Collection Menu
The Collection menu on the Charts display window has the following options:

■ Pause Chart/Resume Chart

Allows you to stop or resume collections for the chart displayed in the chart 
window.

■ Refresh Rate

This option lets you set the amount of elapsed time between data samples. The 
maximum interval is one day and the minimum is one second.

Choose one or all of the following:
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■ Hours - maximum is 23 hours

■ Minutes - maximum is 59 minutes

■ Seconds - maximum is 59 seconds

■ Options

Displays the Options property sheet, from which you can specify the sorting 
criterion, the refresh mechanism, and the number of entries for statistics 
displayed in the Oracle TopSessions main window. 

Drilldown Menu
The Drilldown menu shows the same items available from the Performance 
Manager chart window as well as available drilldowns for the selected sessions. The 
drilldowns available depend on the tools available on your system.  If you choose 
Session Details from the Drilldown menu when no session is selected in the 
TopSessions chart, Performance Manager displays the Select Data Source dialog box 
where you can select from a list of data sources. After you choose the data sources, 
the Session Details window appears.

The Drilldown menu in the TopSessions chart also includes items specific to 
TopSessions. You can end a user session that you select on the TopSessions chart by 
choosing Kill Session from the Drilldown menu. When you kill a session, the 
session is removed from the chart. If a Session Detail window is open when you kill 
its session, the Session Detail window stops refreshing and reports an error.

The Drilldown menu on the TopSessions chart has the following options:

■ Historical Data

Displays the Oracle Capacity Planner Database Logon dialog box. Supply the 
user name, password, and target information as needed. Once you have logged 
into Capacity Planner, you can display historical data for this chart or start 
collecting historical data.

■ Session Details

Displays the Session Details window for the session selected from the Oracle 
TopSessions chart. This menu item is disabled when no session in the Oracle 
TopSessions main display has been selected.

Note: If the Tuning Pack is installed, Current SQL and Explain 
Plan appear on the Drilldown menu.
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■ Current SQL

■ Open Cursors for this Session

■ Timed Statistics

■ List of Drill-Down Charts

List of chart statistics for which you can view additional information (charts).

■ Kill Session

You can kill a session from the Top Sessions chart. This tool requires the 
Intelligent Agent release 8.0.6 or higher.

■ Turn SQL Trace On

■ Turn SQL Trace Off

■ Tune SQL Statement

Highlight an item in a Top Sessions chart and choose the Tune SQL statement 
menu option. If the Tuning Pack is installed, this action activates the SQL 
Analyze application.

Help Menu
The Help menu items allow you to obtain help on Oracle TopSessions chart items or 
property sheets. 

Toolbar
The toolbar of the Oracle TopSessions chart contains icons representing certain 
Oracle TopSessions menu items, including the following: 

Print Screen
Prints the displayed chart.

Report Chart
Generates a report for the displayed chart. When you click the Report Chart button, 
a chart report in HTML format is automatically created and saved for you. 
Performance Manager allows you to preview the report by displaying it on your 
screen.
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Chart Type
Changes the current display to the chart type you select from the drop-down list. 
You can select a bar chart, pie chart, strip chart, or table chart. Bar charts show 
discrete measurements at the current time. Pie charts show the relationship or 
proportions of parts to a whole. Strip charts show trends or changes in data over a 
period of time. When you first display a Strip chart, you will notice the addition 
over time of tics at the bottom of the chart. Each point represents a polling event. 
Table charts present text information, or a large number of instances, in a format 
that is easy to review.

Horizontal Orientation
Changes the chart orientation to horizontal.

Vertical Orientation
Changes the chart orientation to vertical.

Refresh Rate
Allows you to set the time between collections. The time can be set in hours, 
minutes, and seconds.

Pause Chart
Allows you to stop the collection for a chart displayed in the chart window.

Resume Chart
Allows you restart the collection of a chart displayed in the chart window.

Options
Allows you to choose the data sources, data, sort criteria, and number of rows to 
display for the collection.

Historical Data
Displays the Oracle Capacity Planner Database Logon dialog box. Supply the user 
name, password, and service information as needed. Once you have logged into 
Capacity Planner, you can display historical data for this chart or start collecting 
historical data.
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Start Recording
Starts recording the current TopSessions Chart.

Stop Recording
Stops recording the current TopSessions Chart.

Help on Chart
Displays help about the TopSessions chart.

Overview of Session Activity
Once populated with data, the Oracle TopSessions chart includes a multi-column 
list of summary information for each session connected to the database instance, or 
for each of the top n sessions, as measured by the selected sort statistic listed in 
Table 7–1.

Table 7–1 TopSessions Sort Statistics

Sort Statistic Description

Recursive CPU Amount of CPU used for parsing row cache statements such as 
lookups in the data dictionary, executing triggers, and 
PL/SQL.

Parse CPU Amount of CPU time spent parsing SQL statements. The Parse 
CPU filter represents the percentage of CPU time spent parsing 
SQL statements. Parse time CPU can be a strong indication that 
an application has not been well tuned. High parse time CPU 
usually indicates that the application may be spending too 
much time opening and closing cursors or is not using bind 
variables.

Total CPU Time Total elapsed time (in seconds) spent parsing, executing, and 
fetching during a session.

Execute Time Total elapsed time (in seconds) for all calls (user and recursive) 
associated with a distinct session.

Rollback Count Total number of times users manually issue the ROLLBACK 
statement or an error occurs during a user’s transactions 
during the sample period.
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Commit Count Total number of user commits performed during the sample 
period. When a user commits a transaction, the redo generated 
that reflects the changes made to database blocks must be 
written to disk. Commits often represent the closest thing to a 
user transaction rate.

SPID Server Process Identifier is a unique value given to each 
database server process. You must specify an exact id number 
for the filter to work.

Logical Reads (%) Percentage of total buffer gets that were attributed to this 
session during the sample period. Default is 10%.

Physical Reads (%) Percentage of database blocks read from disk. Also known as 
"disk reads." Default is 10%.

Logon Time Time of logon by this session (filter includes sessions that 
started before a user-defined date and time). To set the date 
and time, double click on a piece of the timestamp and use the 
up/down arrows to increase or decrease the value. The default 
timestamp is the current date and time.

UGA Memory Total amount of memory used by the User Global Areas for a 
session.

Parse Elapsed Time Total elapsed time (in seconds) for all parses associated with a 
distinct session.

Action The name of the action being performed by the application 
module that first executed this statement. This name can be 
optionally set by using DMBS_APPLICATION_INFO.SET_
ACTION.

Module The name of the application module that first executed this 
statement. This name can be optionally set by using DMBS_
APPLICATION_INFO.SET_MODULE.

Program The name of the client program. (Useful when the program 
name is known and is distinct from other programs.)

Terminal The operating system terminal name (useful for character 
mode applications).

Machine The operating system machine name.

Table 7–1 TopSessions Sort Statistics

Sort Statistic Description
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OS Username The name of the operating system client user. (Useful in a two 
tier architecture when the database client process does not live 
on a middle tier machine but initiated by the user on his 
desktop, or initiated on a UNIX machine. For desktop initiated 
processes, the Windows registry key USERNAME must be set 
to the username.)

Session Name Either the Oracle username of the current session or if the 
session is owned by an Oracle background process, the name 
of the background process.

Total Parses Total number of parse calls (hard and soft). A parse occurs 
when a SQL statement is mapped to a cursor during a session.

Hard Parses Hard parses happen when the server parses a query and 
cannot find an exact match for the query in the library cache. 
Hard parses can be avoided by sharing SQL statements 
efficiently. The use of bind variables instead of literals in 
queries is one method to increase sharing.

Sort Rows Total number of rows sorted.

Memory Sorts Number of sorts with no disk writes. Sorts in memory are sorts 
that could be performed completely within the sort buffer in 
memory without using the temporary tablespace segments.

Disk Sorts Sorts on disk are sorts too large to be performed entirely in the 
sort area, requiring I/O to temporary segments on disk.

Constant Changes The number of times a database block has applied rollback 
entries to perform a consistent read on the block.

Block Changes The number of times changes were made to blocks in the SGA 
as part of an update or delete. These are changes that are 
generating redo log entries and hence will be permanent 
changes to the database if the transaction is committed.

Phys Reads This data item represents the number of data blocks read from 
disk during this sample period. When a user performs a SQL 
query, Oracle will try to retrieve the data from the database 
buffer cache (memory) first, then go to disk if it is not in 
memory already. Reading data blocks from disk is much more 
expensive than reading the data blocks from memory. The goal 
with Oracle should always be to maximize memory utilization.

Constant Gets Total number of requests for information on constants in the 
data dictionary cache.

Table 7–1 TopSessions Sort Statistics

Sort Statistic Description
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Using the Right Mouse Button on the Main Display
In the Oracle TopSessions chart, you can click on a username with the right mouse 
button and then select one of the menu items that appears in the context menu. The 
list contains the Print Screen, Report Chart, and Help on Chart menu items, and 
then lists the View, Collection, and Drilldown menus from which you can then 
select related items from the flyout menus.

Sorting the Order of Entries in the Chart
By default, the value of the sort statistic determines the order of session entries in 
the Oracle TopSessions chart. However, you can use any field in the list to sort the 
order of displayed session entries by clicking on any column header in the list.

Using the Chart Status Button
Use the Chart Status button in the upper right corner of the TopSessions chart to 
access many of the same options available from the Drilldown menu. You can 
display Advice about the current chart, view the Session Details page,  kill the 
current session, and turn SQL Trace on or off.  The contents of the menu that 
displays when you press the Chart Status button is subject to the context of the 
chart.

Viewing Details About a Given Session
To obtain more information about a given session, you can drill down by right 
mouse clicking on a session in the Oracle TopSessions chart. Click on the Drilldown 

Block Gets Total number of requests for information on blocks in the data 
dictionary cache in CURRENT mode. When Oracle processes a 
user request for data it checks to see if the database blocks 
containing the requested data are in the memory (the database 
buffer cache) first. If so, Oracle checks to see if the data in those 
blocks is "up to date". If they are, Oracle will fulfill the request 
using the data blocks in memory. If they aren’t in memory, 
Oracle will retrieve them from disk. This is less efficient, but 
necessary. If Oracle was able to retrieve the blocks from 
memory without having to apply rollback data for consistency, 
each block retrieved will log a db block get.

Table 7–1 TopSessions Sort Statistics

Sort Statistic Description
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menu item and choose Session Details. Optionally, you can select a session and then 
choose Session Details from the Drilldown menu on the menu bar.

A Session Details window for that session appears as seen in Figure 7–2.

Figure 7–2 TopSessions Details Window

Session Details Page
The Session Details page presents a tabular view of a sessions details and includes 
the following sections:

■ Session Identification Information

■ Current State

■ Session CPU Activity

■ Session Memory Use

■ Session I/O Activity

■ Current SQL

■ Top Wait Events
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Session Details Statistics Page
The Statistics page of the Session Details window provides a large number of 
performance statistics for the selected session. The particular statistics this page 
displays can vary, depending on the Oracle server instance. 

Figure 7–3 Session Statistics Page

For information about the statistics that can be displayed for a session, see the 
Oracle Server Reference. For information on how to make use of these statistics, see 
Oracle Server Tuning.

Customizing the Session Information You Display
To customize how session information is displayed in the Oracle TopSessions chart, 
choose Options from the Collection menu or click on the Options button on the 
toolbar. The Options property sheet that appears includes the following pages:

■ Data

■ Session Filtering
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■ Options

To select one of these pages, click on the appropriate tab title near the top of the 
Options property sheet.

Data Options Page
When TopSessions is selected from the Oracle Performance Manager navigator tree, 
the Data Tab appears in the right-hand pane. The Data Tab presents information 
about the selected TopSessions collection such as the Data Sources and the 
collection types of the selected data. You can personalize the Data Tab view by 
selecting or deselecting the collected data items.

Figure 7–4 TopSessions Data Options Page

Data Sources
The "All data sources" option is selected by default.

Select Collected Data
You can specify which data items should appear in the chart by selecting or 
deselecting the items in this list. By default, a check mark appears in the "Collected 
Data" row, all data items will automatically appear in the chart.
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Session Filtering Options Page
By default, a TopSessions collection will show any session that is currently active or 
any session that has executed a SQL statement since the last sample. These sessions 
are selected based on a default set of pre-defined filters. If you prefer, you can also 
customize the TopSessions collection by defining your own set of TopSessions 
filters. The TopSessions Filtering tab allows you to specify your own set of filters.

Figure 7–5 TopSessions Session Filtering Page

To enable the filtering options, check the box labeled: Show only the statements 
that meet all of the following conditions. Select a filtering condition and value, 
then click the More button to add additional filters. You can eliminate filters by 
pressing the Fewer button.

Creating a Customized TopSessions Collection
Before you create your own set of TopSessions filters, it is important to note the 
following filtering restrictions:

■ You can only include one value per filter.

■ Adding additional filters may negate previously defined filters.
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For a complete list of filtering conditions and their descriptions, see Table 7–1, 
"TopSessions Sort Statistics"  on page 7-10.

Options Page
The Options tab provides two display options. These options should be set prior to 
showing the TopSessions chart. You can also change the options after starting the 
chart to reduce the number of sessions to a smaller sample set based upon some 
abnormality you see in the default chart.

Figure 7–6 TopSessions Options Page

■ Limit to data sources:

No limit--The TopSessions chart will display all of the statements that meet the 
filtering criteria(n).

Limit to--By default the TopSessions chart will only display the top 25 
statements that meet the filtering criteria(n). You can, however, view more or 
fewer statements by adjusting this number.

■ Sort the data by:
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This option allows you to specify a sorting parameter. When the chart is 
displayed, the data items will be organized by the sorting parameter you have 
specified. The chart is sorted by disk reads by default.
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A
Troubleshooting Appendix

This appendix describes different ways of troubleshooting problems that may occur 
when you are using change management applications.

You may decide to contact an Oracle Worldwide Customer Support representative 
regarding a problem with the change management applications. If so, you may be 
asked to use one of the approaches described in this appendix to obtain information 
that will help the representative determine the source of the problem.

Using Environment Variables When Running Change Manager from the 
Command Line

You can set environment variables in the MS-DOS or UNIX command line before 
you run the Change Manager application from the command line. The following 
environment variables may provide information that is useful for troubleshooting 
and debugging change management application problems:

■ set ORACLE_OEM_JAVAMX=-mx<number>m

The default is -mx128m. This environment variable specifies the maximum 
amount of virtual memory to be used by the Java Virtual Machine (in 
megabytes). This memory is not used unless needed. If the amount is exceeded, 
execution will be terminated. This environment variable can be used to increase 
the amount of memory for large script generations and other purposes.

■ set ORACLE_OEM_CLIENTTRACE=true

This environment variable, which is for Windows NT only, displays 
troubleshooting information in an MS-DOS window. Before you set this 
environment variable, the OCM_TRACE.ENABLED property in the ORACLE_
HOME/sysman/config/ClientConfig.properties file (described in Table A–1 on 
page A-2) must be set to true, otherwise troubleshooting information is not 
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displayed in the MS-DOS window. Note that ORACLE_HOME is the directory 
in which Oracle Enterprise Manager is installed.

■ set ORACLE_OEM_JAVARUNTIME=<directory where bin/java.exe is located>

You can specify this environment variable if you have a Java development 
environment. This environment variable can be useful when the system is 
hanging and you want to get a thread dump.

Enabling Tracing and Debugging for Change Management Applications
You can turn on tracing and debugging facilities for the change management 
applications to help troubleshoot problems.

You can enter different properties in the ClientConfig.properties file in the 
ORACLE_HOME/sysman/config directory for Oracle Enterprise Manager to 
obtain more tracing and debugging information about change management 
applications. Table A–1 displays the properties and a description of each property.

By default, the trace files for change management applications are written to the 
ORACLE_HOME/sysman/log directory for Oracle Enterprise Manager.

Note: The OCM_TRACE.ENABLED property in the 
ClientConfig.properties file must be set to true for the other 
properties whose names begin with OCM_TRACE in the 
ClientConfig.properties file to be meaningful.

Table A–1 Using ClientConfig.properties to Enable Tracing and Debugging 

Property and Settings Description

OCM_TRACE.ENABLED={true|false} If true, enables output of 
informational and problem 
trace messages.

OCM_TRACE_FILE.ENABLED={true|false} If true, enables output of 
trace information to a file. 
The setting of the OCM_
TRACE_
VERSIONING.ENABLED 
property determines the 
name of the trace file.
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OCM_TRACE_VERSIONING.ENABLED={true|false} The OCM_TRACE_
FILE.ENABLED property 
must be true for the OCM_
TRACE_
VERSIONING.ENABLED 
property to be meaningful.

If the OCM_TRACE_
VERSIONING.ENABLED 
property is true, a new 
version of the trace file is 
created for each run of the 
application. The file has a 
name in the format Oracle 
Change Manager_
nnnnnn.log, where 
nnnnnn represents a series 
of numbers.

If a change management 
application is running in 
more than one session on 
your machine, examine the 
timestamp of each trace 
file to determine the trace 
file that is associated with 
each session. The trace file 
with the earliest 
timestamp is the trace file 
for the session that started 
first, and so on.

If the OCM_TRACE_
VERSIONING.ENABLED 
property is false or not 
used, the trace file has the 
name Oracle Change 
Manager.log, and the file is 
overwritten for each run of 
the application.

Table A–1 Using ClientConfig.properties to Enable Tracing and Debugging (Cont.)

Property and Settings Description
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OCM_TRACE_DEBUG.ENABLED={true|false} If the OCM_TRACE_
DEBUG.ENABLED 
property is true, general 
debugging information 
(such as property values) 
is output to the trace file 
while Change Manager 
runs.

OCM_TRACE_DEBUG_VERBOSE.ENABLED={true|false} If the OCM_TRACE_
DEBUG_
VERBOSE.ENABLED 
property is true, more 
detailed debugging 
information, including 
class names and line 
numbers, is output to the 
trace file while Change 
Manager runs.

Table A–1 Using ClientConfig.properties to Enable Tracing and Debugging (Cont.)

Property and Settings Description
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VDB_DEBUG={true|false} If the VDB_DEBUG 
property is true, database 
calls are output to the trace 
file.

This property is not 
specific to change 
management applications. 
It can be used with other 
Oracle Enterprise Manager 
applications.

Use this property in the 
ClientConfig.properties 
file to capture database 
calls in the trace file when 
you are running Change 
Manager standalone.

Use this property in the 
omsconfig.properties file 
in the $ORACLE_
HOME/sysman/config 
directory to capture 
database calls in the trace 
file when you are running 
Change Manager 
connected to an Oracle 
Management Server.

Use this property in both 
the 
ClientConfig.properties 
file and the 
omsconfig.properties file if 
you want to capture 
database calls in the trace 
file regardless of how you 
are running Change 
Manager.

Table A–1 Using ClientConfig.properties to Enable Tracing and Debugging (Cont.)

Property and Settings Description
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VDB_VERBOSE_DEBUG={true|false} If the VDB_VERBOSE_
DEBUG property is true, 
more detailed information 
about database calls, 
including SQL statement 
issued and return values, 
is output to the trace file.

This property is not 
specific to change 
management applications. 
It can be used with other 
Oracle Enterprise Manager 
applications.

Use this property in the 
ClientConfig.properties 
file to capture database 
calls in the trace file when 
you are running Change 
Manager standalone.

Use this property in the 
omsconfig.properties file 
in the $ORACLE_
HOME/sysman/config 
directory to capture 
database calls in the trace 
file when you are running 
Change Manager 
connected to an Oracle 
Management Server.

Use this property in both 
the 
ClientConfig.properties 
file and the 
omsconfig.properties file if 
you want to capture 
database calls in the trace 
file regardless of how you 
are running Change 
Manager.

Table A–1 Using ClientConfig.properties to Enable Tracing and Debugging (Cont.)

Property and Settings Description
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